Browse Source

Gate Fixes for Drydock

* pep8 fixes for airship-drydock-omni-test
* Install requirements sequential for ubuntu_xenial image
* Install older version of pip<21.0 for ubuntu_xenial image

Change-Id: If494b6abc1f8b85d96da4cad2da8606b8b2a1352
changes/02/791802/2
anthony.bellino 4 months ago
parent
commit
b04304094f
  1. 6
      images/drydock/Dockerfile.ubuntu_xenial
  2. 4
      python/requirements-lock.txt

6
images/drydock/Dockerfile.ubuntu_xenial

@ -92,10 +92,10 @@ ENV LD_LIBRARY_PATH=/usr/local/lib
COPY --from=baclient_builder /usr/local/lib /usr/local/lib
COPY --from=baclient_builder /usr/local/include/yaml.h /usr/local/include/yaml.h
RUN python3 -m pip install -U 'pip<21.0'
COPY ./python/requirements-lock.txt /tmp/drydock/
RUN pip3 install \
--no-cache-dir \
-r /tmp/drydock/requirements-lock.txt
RUN cat /tmp/drydock/requirements-lock.txt | xargs -d '\n' \
-l1 pip3 -vv install --no-cache-dir
COPY ./python /tmp/drydock/python
WORKDIR /tmp/drydock/python

4
python/requirements-lock.txt

@ -1,5 +1,5 @@
alembic==0.8.2
amqp==2.3.2
amqp==2.6.0
Babel==2.6.0
Beaker==1.9.1
cachetools==2.1.0
@ -65,7 +65,7 @@ PyYAML==5.3.1
redfish==2.0.1
repoze.lru==0.7
requests==2.22.0
rfc3986==1.1.0
rfc3986==1.2.0
Routes==2.4.1
setuptools==40.4.3
six==1.15.0

Loading…
Cancel
Save