A configuration organization tool.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

39 lines
1.0 KiB

[[source]]
name = "pypi"
url = "https://pypi.org/simple"
verify_ssl = true
[dev-packages]
pytest = "*"
pytest-cov = "*"
testfixtures = "*"
pytest-xdist = "*"
requests = ">=2.20.0"
urllib3 = ">=1.24.3"
chardet = ">=3.0.4"
flake8 = "*"
yapf = "~=0.28.0"
hacking = ">=1.1.0"
flake8-import-order = ">=0.18.1"
bandit = ">=1.6.0"
[packages]
click = ">=6.7"
jsonschema = ">=3.0.1<4"
cryptography = ">=2.7"
python-dateutil = ">=2.8.1"
GitPython = "~=2.1.11"
docker = ">=3.7.2"
pylibyaml = "~=0.1"
PyYAML = "~=5.1"
deckhand = {git = "https://opendev.org/airship/deckhand.git",ref = "d7d3cbde2bd44eed0d574ec439d1f8194dbcf782"}
shipyard-client = {git = "https://opendev.org/airship/shipyard.git",ref = "35e5a7f796a5341e02fb0d3f2d27b41e2fb39131",subdirectory = "src/bin/shipyard_client"}
promenade = {git = "https://opendev.org/airship/promenade.git",ref = "bc14e9bbb9857becedd7ce9d6b81d74de77b497b"}
"oslo.i18n" = "~=3.24.0"
"oslo.utils" = ">=3.42.1"
six = ">=1.15.0"
debtcollector = "~=1.22.0"
zipp = "~=1.2.0"
[requires]
python_version = "3.6"