Browse Source

fix - pep8 and image build gates

This commit updates the Pegleg pep8 gate to use Ubuntu 18.04 (bionic) as
the base Ubuntu image for the job. Upstream CI has a community goal to
use Ubuntu 20.04 (focal) which defaults to python3.8. By moving to
python3.8, some of the pip packages need to be updated but until pip
conflicts are resolved, it is difficult to do so.

Additionally, update the deb-docker path to fix the docker image build
jobs.

Change-Id: I263c646f9fbf14cb65267df586c524de3da2878f
changes/51/752951/12
Rick Bartra 9 months ago
parent
commit
9853fcfbee
2 changed files with 3 additions and 3 deletions
  1. +2
    -2
      .zuul.yaml
  2. +1
    -1
      tools/zuul/playbooks/docker-image-build.yaml

+ 2
- 2
.zuul.yaml View File

@ -18,7 +18,7 @@
rtd_project_name: 'airship-promenade'
check:
jobs:
- openstack-tox-pep8
- openstack-tox-pep8-bionic
- airship-promenade-lint-ws
- airship-promenade-docker-build-gate-ubuntu_xenial
- airship-promenade-docker-build-gate-ubuntu_bionic
@ -30,7 +30,7 @@
gate:
jobs:
- openstack-tox-pep8
- openstack-tox-pep8-bionic
- airship-promenade-lint-ws
- airship-promenade-docker-build-gate-ubuntu_xenial
- airship-promenade-docker-build-gate-ubuntu_bionic


+ 1
- 1
tools/zuul/playbooks/docker-image-build.yaml View File

@ -27,7 +27,7 @@
- apt_key:
url: https://download.docker.com/linux/ubuntu/gpg
- apt_repository:
repo: deb http://{{ zuul_site_mirror_fqdn }}/deb-docker xenial stable
repo: deb http://{{ zuul_site_mirror_fqdn }}/deb-docker/{{ ansible_distribution_release }} {{ ansible_distribution_release }} stable
- apt:
name: "{{ item }}"
allow_unauthenticated: True


Loading…
Cancel
Save