Browse Source

Remove setuptools from requirements

Setuptools is currently listed as a requirement for shipyard-client, but
it is not used. Pegging setuptools forces downgrading when installing
shipyard-client, which can cause issues for packages that attempt to
utilize features found in newer versions of setuptools. Removing the
setuptools requirements will allow installing users to choose their own
version of setuptools to use.

Change-Id: I88570b69346ec7019e753bdd8681fd63d55dc8c8
changes/10/671110/1
Ian H Pittwood 2 years ago
parent
commit
9bf298fea7
1 changed files with 0 additions and 1 deletions
  1. +0
    -1
      src/bin/shipyard_client/requirements.txt

+ 0
- 1
src/bin/shipyard_client/requirements.txt View File

@ -19,6 +19,5 @@ click==6.7
click-default-group==1.2
keystoneauth1==3.11.1
requests==2.20.0
setuptools==40.4.1
PTable==0.9.2
pyyaml==5.1

Loading…
Cancel
Save