Browse Source

(airflow) - Requirements update for apache airflow

Updated airflow requirements list needed for apache airflow 1.10.4 and later.

Change-Id: I142e46e4fa202d216287ea2f663bd4811e47f0ba
changes/12/686412/1
Ahmad Mahmoudi 2 years ago
parent
commit
e6c7a6e1a5
2 changed files with 4 additions and 0 deletions
  1. +2
    -0
      images/airflow/requirements.txt
  2. +2
    -0
      src/bin/shipyard_airflow/requirements.txt

+ 2
- 0
images/airflow/requirements.txt View File

@ -22,7 +22,9 @@ docker==3.5.0
# overriding where it is sourced from
python-openstackclient==3.16.1
kubernetes>=6.0.0
# Need to lock marshmellow-sqlalchemy and tabulate for compatibility issues
marshmallow-sqlalchemy==0.18.0
tabulate==0.8.03
# Dependencies for other UCP components
git+https://git.openstack.org/openstack/airship-deckhand@7e5d81f50f1f8c0d58d0973ae0b3065fd5b62451#egg=deckhand


+ 2
- 0
src/bin/shipyard_airflow/requirements.txt View File

@ -37,7 +37,9 @@ uwsgi==2.0.17
# To support profiling in non-prod
Werkzeug>=0.15.0
# Need to lock marshmellow-sqlalchemy and tabulate for compatibility issues
marshmallow-sqlalchemy==0.18.0
tabulate==0.8.03
# Dependencies for other UCP components
git+https://git.openstack.org/openstack/airship-deckhand@7e5d81f50f1f8c0d58d0973ae0b3065fd5b62451#egg=deckhand


Loading…
Cancel
Save