Browse Source

Update dependencies to match other projects

Deckhand's requirement for keystoneauth1 (3.11.1) does not match with
the version used by Shipyard Client (3.11.0). In addition, Shipyard
Client uses requests-2.19.1 which is an insecure version of requests.
Both of these requirements conflict with other Airship project
dependencies. These conflicts become apparent in Pegleg, which uses both
Shipyard Client and Deckhand. The updates made in this change make
Shipyard Client compatible with Pegleg's own dependencies and other
projects it imports from.

Upticks keystoneauth1 to 3.11.1, a bugfix which should not impact
Shipyard Client behavior.

Upticks requests to 2.20.0, which contains several bug fixes and
deprecates support for py26.

Change-Id: I8716c56351e90bca8e7dbdf672638a45f15c655a
changes/85/664985/3
Ian H. Pittwood 2 years ago
committed by Ian Pittwood
parent
commit
efb21f2958
  1. 4
      src/bin/shipyard_client/requirements.txt

4
src/bin/shipyard_client/requirements.txt

@ -17,8 +17,8 @@
arrow==0.12.1
click==6.7
click-default-group==1.2
keystoneauth1==3.11.0
requests==2.19.1
keystoneauth1==3.11.1
requests==2.20.0
setuptools==40.4.1
PTable==0.9.2
pyyaml==3.13
Loading…
Cancel
Save