airskiff: Pin Armada to K8s v2.11.0

Currently, OpenStack-Helm-Infra uses version 2.11.0 of Kubernetes.
Because Airskiff uses OpenStack-Helm-Infra for deployment of K8s, newer
versions of Armada cause the Airskiff gate to fail, as Armada now uses
Tiller v2.12.1. This commit pins Armada to the latest version that
utilized Tiller v2.11.0. This pin should be removed as soon as
OpenStack-Helm-Infra moves to v2.12.1.

Change-Id: Iaa3a776ffda9678b7736c1b1aac72a1adbedf29b
changes/98/630698/3
Drew Walters 4 years ago
parent e6cce0cbf8
commit 6e7dc091a1
  1. 2
      .zuul.yaml
  2. 5
      tools/deployment/airskiff/developer/005-make-airship.sh
  3. 3
      tools/deployment/airskiff/developer/030-armada-bootstrap.sh

@ -45,6 +45,8 @@
post-run: tools/gate/playbooks/debug-report.yaml
required-projects:
- name: openstack/airship-armada
# NOTE(drewwalters96): Temporarily pin Armada to K8s v2.11.0.
override-checkout: dd75474d78e69f3634eb94c8ea6730b898e83277
- name: openstack/airship-deckhand
- name: openstack/airship-pegleg
- name: openstack/airship-shipyard

@ -25,7 +25,10 @@ CURRENT_DIR="$(pwd)"
cd ${INSTALL_PATH}
git clone https://git.openstack.org/openstack/airship-armada.git
cd airship-armada && make images
cd airship-armada
# NOTE(drewwalters96): Temporarily pin Armada to K8s v2.11.0.
git checkout dd75474d78e69f3634eb94c8ea6730b898e83277
make images IMAGE_TAG=dd75474d78e69f3634eb94c8ea6730b898e83277
cd ${INSTALL_PATH}
git clone https://git.openstack.org/openstack/airship-deckhand.git

@ -20,9 +20,10 @@ set -xe
: "${INSTALL_PATH:="$(pwd)/../"}"
# Download latest Armada image and deploy Airship components
# NOTE(drewwalters96): Temporarily pin Armada to K8s v2.11.0.
docker run --rm --net host -p 8000:8000 --name armada \
-v ~/.kube/config:/armada/.kube/config \
-v "$(pwd)"/tools/deployment/airskiff/manifests/:/manifests \
-v "${INSTALL_PATH}":/airship-components \
quay.io/airshipit/armada:latest \
quay.io/airshipit/armada:dd75474d78e69f3634eb94c8ea6730b898e83277 \
apply /manifests/airship.yaml

Loading…
Cancel
Save