Browse Source

Uplift Kubernetes to version 1.10.11

This addresses a critical security vulnerability.

Change-Id: I76dbc59d2b5d4a85c72e16eb3fe7f760b01a53f7
Mark Burnett 4 months ago
parent
commit
d8d80d9b66
1 changed files with 10 additions and 10 deletions
  1. 10
    10
      global/software/config/versions.yaml

+ 10
- 10
global/software/config/versions.yaml View File

@@ -452,7 +452,7 @@ data:
452 452
         subpath: helm-toolkit
453 453
         type: git
454 454
   files:
455
-    kubelet: https://dl.k8s.io/v1.10.2/kubernetes-node-linux-amd64.tar.gz
455
+    kubelet: https://dl.k8s.io/v1.10.11/kubernetes-node-linux-amd64.tar.gz
456 456
   images:
457 457
     calico:
458 458
       calico: {}
@@ -470,27 +470,27 @@ data:
470 470
       tenant-ceph-rgw: {}
471 471
     kubernetes:
472 472
       apiserver:
473
-        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.2
474
-        apiserver: gcr.io/google-containers/hyperkube-amd64:v1.10.2
473
+        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.11
474
+        apiserver: gcr.io/google-containers/hyperkube-amd64:v1.10.11
475 475
       controller-manager:
476
-        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.2
477
-        controller_manager: gcr.io/google-containers/hyperkube-amd64:v1.10.2
476
+        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.11
477
+        controller_manager: gcr.io/google-containers/hyperkube-amd64:v1.10.11
478 478
       coredns:
479 479
         coredns: docker.io/coredns/coredns:1.1.2
480 480
       etcd:
481 481
         etcd: quay.io/coreos/etcd:v3.2.14
482 482
         etcdctl: quay.io/coreos/etcd:v3.2.14
483 483
       haproxy:
484
-        anchor: gcr.io/google_containers/hyperkube-amd64:v1.10.2
484
+        anchor: gcr.io/google_containers/hyperkube-amd64:v1.10.11
485 485
         haproxy: docker.io/haproxy:1.8.3
486 486
       ingress: {}
487
-      kubectl: gcr.io/google-containers/hyperkube-amd64:v1.10.2
487
+      kubectl: gcr.io/google-containers/hyperkube-amd64:v1.10.11
488 488
       pause: gcr.io/google-containers/pause-amd64:3.1
489 489
       proxy:
490
-        proxy: gcr.io/google-containers/hyperkube-amd64:v1.10.2
490
+        proxy: gcr.io/google-containers/hyperkube-amd64:v1.10.11
491 491
       scheduler:
492
-        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.2
493
-        scheduler: gcr.io/google-containers/hyperkube-amd64:v1.10.2
492
+        anchor: gcr.io/google-containers/hyperkube-amd64:v1.10.11
493
+        scheduler: gcr.io/google-containers/hyperkube-amd64:v1.10.11
494 494
     osh:
495 495
       barbican: {}
496 496
       cinder: {}

Loading…
Cancel
Save