Commit Graph

25 Commits (master)

Author SHA1 Message Date
Pau Espin Pedrol 76f417da09 requirements.txt: Avoid depending on PyYAML<6 8 months ago
Evgeni Golov 9c7dbb6392 force pre 2.0 stevedore on Python 2 2 years ago
Thomas Bechtold 23079af777 Allow pyyaml >= 5 4 years ago
Vicky Chijwani 0deb58146a Constrain PyYAML to v3.x. 5 years ago
Sorin Sbarnea 705051658f bump python-jenkins version 5 years ago
Darragh Bailey af9d984baa
Basic folder support 5 years ago
Daniel Watkins b95f194612 Add !include-jinja2 for rendering templates with Jinja2 5 years ago
Darragh Bailey 6e237c4369 Allow using lockfile per jenkins master 6 years ago
Monty Taylor 503fd8dcd4
Sync requirements with openstack/requirements 6 years ago
liyuanzhen e70e1f2bf4 Not limit stevedore to 1.8.0 6 years ago
Wayne fc73cedb45 Introduce modular implementation of subcommands. 7 years ago
Thomas Bechtold 389afe422c Remove ordereddict support from py26 7 years ago
Darragh Bailey 3faecfd76a Add separate linkcheck env and allow dev to select builder 7 years ago
Ken Dreyer 34570607e2 rm argparse from requirements.txt 7 years ago
Khai Do 67de07ceed Improve delete all job performance 7 years ago
Emilien Macchi 4f146bc3e8 requirements: pin pbr>=0.8.2,<2.0 8 years ago
Jeremy Stanley 520f3c5459 Depend on python-jenkins 0.4.1 or later 8 years ago
Marc Abramowitz 64e217f885 Make JJB python 3 compatible 8 years ago
Darragh Bailey 2d74b16620 Move ordereddict to requirements 8 years ago
Clark Boylan 405ff049ff Revert "Some tweaks to get closer to Python 3 compat" 8 years ago
Marc Abramowitz 1d7647fa85 Some tweaks to get closer to Python 3 compat 8 years ago
Darragh Bailey fd82f48a84 Argparse is required for JJB to parse arguments 8 years ago
Marc Abramowitz b33ac74828 Add tox "coverage" target 9 years ago
Antoine Musso d2ff8c098f Migrate to pbr 9 years ago
James E. Blair 0c2bef0803 Add test to determine whether XML output has changed. 10 years ago