Browse Source

Blacklist stestr 3.0.0 and drop pypy

stestr 3.0.0 does not support python 2.7 but has been released without
the proper metadata to reflect that. As a result, there is a python2 wheel
stestr-3.0.0-py2-none-any.whl which get picked up.

Blacklist stestr 3.0.0 to fix '--list': no such option error

Drop pypy testing since pypy jobs are always failling.

Signed-off-by: Antoine Musso <hashar@free.fr>
Signed-off-by: Andreas Jaeger <aj@suse.com>
Change-Id: Ia2f7c814f21c78f29ec9024997469625f92bc401
changes/73/719073/4
Kazuhiro Suzuki 1 year ago
committed by Antoine Musso
parent
commit
36f0b89766
  1. 2
      .zuul.yaml
  2. 2
      test-requirements.txt
  3. 2
      tox.ini

2
.zuul.yaml

@ -18,8 +18,6 @@
jobs:
- openstack-tox-linters
- openstack-tox-py27
- openstack-tox-pypy:
nodeset: ubuntu-bionic
- jjb-tox-cross-jenkins-job-builder
gate:
jobs:

2
test-requirements.txt

@ -8,7 +8,7 @@ requests-mock>=1.4.0
requests-kerberos
sphinx>=1.6.0,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.6.0;python_version>='3.4' # BSD
stestr>=2.0.0
stestr>=2.0.0,!=3.0.0
testscenarios
testtools
pre-commit

2
tox.ini

@ -1,7 +1,7 @@
[tox]
minversion = 2.0
skipsdist = True
envlist = py{34,27,35,36}, linters, pypy
envlist = py{34,27,35,36}, linters
[testenv]
setenv =

Loading…
Cancel
Save