Browse Source

Add old python packaging pin

The packaging package doesn't support python3.5 or older anymore. Bindep
is still occasionally used on systems without newer python. Add an
environment marker to our requirements to install older packaging on
those systems.

Change-Id: I28949b0bb7d4978fc7f71109d0c65b9b76d6563f
changes/47/814647/2 2.10.1
Clark Boylan 7 months ago
parent
commit
0bd79b1d5d
  1. 3
      requirements.txt

3
requirements.txt

@ -1,4 +1,5 @@
distro
pbr>=2.0.0 # Apache-2.0
Parsley
packaging
packaging ; python_version >= '3.6'
packaging<21.0 ; python_version < '3.6'

Loading…
Cancel
Save