Browse Source

Use new infra_spec_helper for gem dependencies

Change-Id: I1a5743fa780b55f15dae0d2867d1eb65cfd666a7
Spencer Krum 2 years ago
parent
commit
1348e723d2
1 changed files with 4 additions and 32 deletions
  1. 4
    32
      Gemfile

+ 4
- 32
Gemfile View File

@@ -1,37 +1,9 @@
1 1
 source 'https://rubygems.org'
2 2
 
3
-group :development, :test do
4
-  gem 'puppetlabs_spec_helper', :require => false
5
-
6
-  # Pin google-api-client after it released a ruby 2.0 only version
7
-  gem 'google-api-client', '0.9.4'
8
-
9
-  gem 'metadata-json-lint'
10
-  # This is nice and all, but let's not worry about it until we've actually
11
-  # got puppet 4.x sorted
12
-  # gem 'puppet-lint-param-docs'
13
-  gem 'puppet-lint-absolute_classname-check'
14
-  gem 'puppet-lint-absolute_template_path'
15
-  gem 'puppet-lint-trailing_newline-check'
16
-
17
-  # Puppet 4.x related lint checks
18
-  gem 'puppet-lint-unquoted_string-check'
19
-  # Disable it because we use empty string checks
20
-  #gem 'puppet-lint-empty_string-check'
21
-  gem 'puppet-lint-leading_zero-check'
22
-  gem 'puppet-lint-variable_contains_upcase'
23
-  gem 'puppet-lint-spaceship_operator_without_tag-check'
24
-  gem 'puppet-lint-undef_in_function-check'
25
-
26
-  if puppetversion = ENV['PUPPET_GEM_VERSION']
27
-    gem 'puppet', puppetversion, :require => false
28
-  else
29
-    gem 'puppet', '~> 3.0', :require => false
30
-  end
31
-end
32
-
33
-group :system_tests do
34
-  gem 'beaker-rspec', :require => false
3
+group :development, :test, :system_tests do
4
+  gem 'puppet-openstack_infra_spec_helper',
5
+      :git     => 'https://git.openstack.org/openstack-infra/puppet-openstack_infra_spec_helper',
6
+      :require => false
35 7
 end
36 8
 
37 9
 # vim:ft=ruby

Loading…
Cancel
Save