Browse Source

Add standard puppet module files and .gitreview

This module has been split out from system-config, and additional
files are required to create a proper puppet module. Fix puppet
lint compliance.

Some of the files are described in the spec:
http://specs.openstack.org/openstack-infra/infra-specs/specs/puppet-modules.html

Change-Id: I92480816910b312de8b05e740147b2e5d627a018
changes/38/151138/2
Marton Kiss 7 years ago
parent
commit
28709a561b
  1. 4
      .gitreview
  2. 8
      Rakefile
  3. 4
      manifests/init.pp
  4. 23
      metadata.json

4
.gitreview

@ -0,0 +1,4 @@
[gerrit]
host=review.openstack.org
port=29418
project=openstack-infra/puppet-mediawiki.git

8
Rakefile

@ -0,0 +1,8 @@
require 'rubygems'
require 'puppetlabs_spec_helper/rake_tasks'
require 'puppet-lint/tasks/puppet-lint'
PuppetLint.configuration.fail_on_warnings = true
PuppetLint.configuration.send('disable_80chars')
PuppetLint.configuration.send('disable_autoloader_layout')
PuppetLint.configuration.send('disable_class_inherits_from_params_class')
PuppetLint.configuration.send('disable_class_parameter_defaults')

4
manifests/init.pp

@ -16,9 +16,7 @@ class mediawiki(
if ($role == 'app' or $role == 'all') {
# This is equivalent to apache::dev which is not puppet3
# compatible with puppetlabs-apache 0.0.4:
package { ['libaprutil1-dev',
'libapr1-dev',
'apache2-prefork-dev']:
package { ['libaprutil1-dev', 'libapr1-dev', 'apache2-prefork-dev']:
ensure => present,
}

23
metadata.json

@ -0,0 +1,23 @@
{
"name": "openstackci-mediawiki",
"version": "0.0.1",
"author": "Openstack CI",
"summary": "Puppet module for mediawiki",
"license": "Apache 2.0",
"source": "git://git.openstack.org/openstack-infra/puppet-mediawiki.git",
"project_page": "http://ci.openstack.org/",
"issues_url": "https://storyboard.openstack.org/#!/project/775",
"operatingsystem_support": [
{ "operatingsystem": "Ubuntu", "operatingsystemrelease": ["12.04"] }
],
"requirements": [
{ "name": "pe", "version_requirement": ">= 3.2.0 < 3.4.0" },
{ "name": "puppet", "version_requirement": "3.x" }
],
"dependencies": [
{ "name": "puppetlabs/stdlib", "version_requirement": ">= 3.2.0" },
{ "name": "puppetlabs/apache", "version_requirement": "= 0.0.4" },
{ "name": "openstackci/vcsrepo", "version_requirement": "= 0.0.8" }
]
}
Loading…
Cancel
Save