Browse Source

Update nodejs default version

default nodejs version installed on ubuntu xenial
is too old ( 4.x ) and wanst installing npm package
thus deployment was failing bc its relaying on that one
added repo_url_suffix attribute to class nodejs to force
to install version 9.x

Change-Id: I4f3fe711acaffdf7340c49dc9aca095bbbf10a68
Sebastian Marcet 2 months ago
parent
commit
db89f2367c
1 changed files with 16 additions and 15 deletions
  1. 16
    15
      manifests/init.pp

+ 16
- 15
manifests/init.pp View File

@@ -297,8 +297,9 @@ class openstackid (
297 297
     }
298 298
   }
299 299
 
300
-  # install nodejs default version
300
+  # force 10.x version
301 301
   class { '::nodejs':
302
+    repo_url_suffix => '10.x',
302 303
   }
303 304
 
304 305
   group { 'openstackid':
@@ -322,14 +323,14 @@ class openstackid (
322 323
   }
323 324
 
324 325
   file { '/etc/openstackid/.env':
325
-        ensure  => present,
326
-        content => template('openstackid/.env.erb'),
327
-        owner   => 'root',
328
-        group   => 'www-data',
329
-        mode    => '0640',
330
-        require => [
331
-          File['/etc/openstackid'],
332
-        ]
326
+    ensure  => present,
327
+    content => template('openstackid/.env.erb'),
328
+    owner   => 'root',
329
+    group   => 'www-data',
330
+    mode    => '0640',
331
+    require => [
332
+      File['/etc/openstackid'],
333
+    ]
333 334
   }
334 335
 
335 336
   # mysql ssl connection configuration
@@ -460,12 +461,12 @@ class openstackid (
460 461
   }
461 462
 
462 463
   $deploy_site_requires =  [
463
-        File['/opt/deploy/conf.d/openstackid.conf'],
464
-        Apache::Vhost::Custom[$vhost_name],
465
-        File['/etc/openstackid/.env'],
466
-        Package['curl'],
467
-        Package[$php_packages] ,
468
-        Class['::nodejs'],
464
+    File['/opt/deploy/conf.d/openstackid.conf'],
465
+    Apache::Vhost::Custom[$vhost_name],
466
+    File['/etc/openstackid/.env'],
467
+    Package['curl'],
468
+    Package[$php_packages] ,
469
+    Class['::nodejs'],
469 470
   ]
470 471
 
471 472
   $update_site_requires = [

Loading…
Cancel
Save