Puppet module for Project_config
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

Gemfile 1.0KB

123456789101112131415161718192021222324252627282930313233343536
  1. source 'https://rubygems.org'
  2. group :development, :test do
  3. gem 'puppetlabs_spec_helper', :require => false
  4. # Pin google-api-client after it released a ruby 2.0 only version
  5. gem 'google-api-client', '0.9.4'
  6. gem 'metadata-json-lint'
  7. # This is nice and all, but let's not worry about it until we've actually
  8. # got puppet 4.x sorted
  9. # gem 'puppet-lint-param-docs'
  10. gem 'puppet-lint-absolute_classname-check'
  11. gem 'puppet-lint-absolute_template_path'
  12. gem 'puppet-lint-trailing_newline-check'
  13. # Puppet 4.x related lint checks
  14. gem 'puppet-lint-unquoted_string-check'
  15. gem 'puppet-lint-empty_string-check'
  16. gem 'puppet-lint-leading_zero-check'
  17. gem 'puppet-lint-variable_contains_upcase'
  18. gem 'puppet-lint-spaceship_operator_without_tag-check'
  19. gem 'puppet-lint-undef_in_function-check'
  20. if puppetversion = ENV['PUPPET_GEM_VERSION']
  21. gem 'puppet', puppetversion, :require => false
  22. else
  23. gem 'puppet', '~> 3.0', :require => false
  24. end
  25. end
  26. group :system_tests do
  27. gem 'beaker-rspec', :require => false
  28. end
  29. # vim:ft=ruby