Browse Source

Pin statsd to version 2.1.2

The os-performance-tools library currently caps its statsd dependency at
<3.0[1]. If we try to install latest, puppet will succeed at installing
it in the first place, but upon the next run it will see that it is not
using the latest and try to upgrade and fail due to the cap. Add the pin
so that it doesn't try and fail to install something it can't.

[1] http://git.openstack.org/cgit/openstack/os-performance-tools/tree/requirements.txt?id=d96d5145fa5facdfd7a4e5ea2811948f0efd465e#n7

Change-Id: I37303d3b23cf5c387511292a8e128faa1f9df9ae
changes/34/581334/1
Colleen Murphy 10 months ago
parent
commit
2d4e2178fe
1 changed files with 5 additions and 1 deletions
  1. 5
    1
      manifests/init.pp

+ 5
- 1
manifests/init.pp View File

@@ -95,7 +95,11 @@ class subunit2sql (
95 95
 
96 96
   if ! defined(Package['statsd']) {
97 97
     package { 'statsd':
98
-      ensure   => latest,
98
+      # NOTE(cmurphy) If this is not pinned, the openstack_pip provider will
99
+      # attempt to install latest and conflict with the <3 cap from
100
+      # os-performance-tools. Unpin this when os-performance-tools raises its
101
+      # cap.
102
+      ensure   => '2.1.2',
99 103
       provider => openstack_pip,
100 104
       require  => Class['pip']
101 105
     }

Loading…
Cancel
Save