Browse Source

Don't install python-yaml package

PyYAML is already a dependency of subunit2sql, so the distro package
doesn't need to be installed explicitly. If it is installed by the
distro, then on a system with pip 10 the subunit2sql installation will
fail.

Change-Id: Ie7be5cf01fcf9a630c7bf282549a862515c159d9
changes/11/581111/1
Colleen Murphy 11 months ago
parent
commit
3b44d63528
1 changed files with 0 additions and 7 deletions
  1. 0
    7
      manifests/init.pp

+ 0
- 7
manifests/init.pp View File

@@ -85,12 +85,6 @@ class subunit2sql (
85 85
     }
86 86
   }
87 87
 
88
-  if ! defined(Package['python-yaml']) {
89
-    package { 'python-yaml':
90
-      ensure => present,
91
-    }
92
-  }
93
-
94 88
   if ! defined(Package['gear']) {
95 89
     package { 'gear':
96 90
       ensure   => latest,
@@ -116,7 +110,6 @@ class subunit2sql (
116 110
     require => [
117 111
       Package['python-daemon'],
118 112
       Package['python-zmq'],
119
-      Package['python-yaml'],
120 113
       Package['gear'],
121 114
       Exec['install-subunit2sql-safely'],
122 115
       Package['python-subunit'],

Loading…
Cancel
Save