Browse Source

Make subunit2sql install depend on netifaces

In order to make sure pip installation of subunit2sql does not
attempt to pip install (and subsequently build from sdist)
netifaces, set a dependency ensuring the distro package for
python-netifaces is installed before that.

Change-Id: I01118c2771aa4e4fa553fb04b4a0885bf977a738
Jeremy Stanley 1 year ago
parent
commit
69150752a0
1 changed files with 2 additions and 1 deletions
  1. 2
    1
      manifests/init.pp

+ 2
- 1
manifests/init.pp View File

@@ -43,7 +43,8 @@ class subunit2sql (
43 43
     require  => [
44 44
       Class['pip'],
45 45
       Package['python-mysqldb'],
46
-      Package['python-psycopg2']
46
+      Package['python-psycopg2'],
47
+      Package['python-netifaces']
47 48
     ],
48 49
   }
49 50
 

Loading…
Cancel
Save