Install pip3 for docker-compose installation

We need newer docker-compose for functionality like stop_grace_period
and the easiest way to get that is via pypi. To install from there we
need pip.

This also fixes pip3 to work on xenial which doesn't have a
python3-distutils package.

Change-Id: I5f5431cac7eb191f2f5443892292ca5a236fe1e6
changes/20/720820/2
Clark Boylan 3 years ago
parent 5e4901b7c6
commit 02a81a5c7f

@ -23,6 +23,10 @@
- docker-compose
state: absent
- name: ensure pip3 is installed
include_role:
name: pip3
- name: Install docker-compose
pip:
name: docker-compose

@ -7,11 +7,14 @@
# NOTE(ianw) : See https://github.com/pypa/get-pip/issues/43;
# requirement of get-pip.py
# Xenial doesn't have python3-distutils as it appears to be part
# of python3 itself.
- name: Ensure distutils
package:
name:
- python3-distutils
state: present
when: ansible_distribution_release != 'xenial'
- name: Download get-pip.py
command: wget https://bootstrap.pypa.io/get-pip.py

Loading…
Cancel
Save