Browse Source

Install pbr in pip3 role to fix issue xenial

When installing bots on eavesdrop with py27/py35, there is a
regression with the latest pbr release. The workaround is to
have pbr preinstalled in the pip3 role.

Change-Id: I5ea790a50e180df36b480dcbb13530a80f398b5e
changes/42/793242/3
Jens Harbott 1 year ago
parent
commit
88139ef622
  1. 10
      playbooks/roles/pip3/tasks/main.yaml

10
playbooks/roles/pip3/tasks/main.yaml

@ -39,3 +39,13 @@
loop:
- pip
- virtualenv
# TODO(frickler): pbr is being installed as a workaround for issues
# with eavesdrop running on xenial with py27/35. It can be dropped
# once the host has been upgraded
- name: Install latest pbr on xenial
pip:
name: pbr
state: latest
executable: pip3
when: ansible_distribution_release == 'xenial'

Loading…
Cancel
Save