Browse Source

Indicate firefox is suboptimal in meetpad

Remove firefox from the "optimal browsers" list so that when someone
joins with ff, they get a message indicating that another browser is
recommended.  They can still join.

Also disable background blurring, since that currently seems to be
producing a poor experience when used.

Change-Id: Ie161fef6351337c4e1102d1ab645367a71e5b4bf
changes/22/733022/1
James E. Blair 2 years ago
parent
commit
bc646edc3c
  1. 6
      playbooks/roles/jitsi-meet/files/interface_config.js

6
playbooks/roles/jitsi-meet/files/interface_config.js

@ -9,7 +9,7 @@ var interfaceConfig = {
* Whether or not the blurred video background for large video should be
* displayed on browsers that can support it.
*/
DISABLE_VIDEO_BACKGROUND: false,
DISABLE_VIDEO_BACKGROUND: true,
INITIAL_TOOLBAR_TIMEOUT: 20000,
TOOLBAR_TIMEOUT: 4000,
@ -50,7 +50,7 @@ var interfaceConfig = {
'fodeviceselection', 'hangup', 'profile', 'info', 'chat', 'recording',
'livestreaming', 'etherpad', 'sharedvideo', 'settings', 'raisehand',
'videoquality', 'filmstrip', 'invite', 'feedback', 'stats', 'shortcuts',
'tileview', 'videobackgroundblur'
'tileview'
],
SETTINGS_SECTIONS: [ 'devices', 'language', 'moderator', 'profile', 'calendar' ],
@ -173,7 +173,7 @@ var interfaceConfig = {
// has a suboptimal experience. Browsers which are not listed as optimal or
// unsupported are considered suboptimal. Valid values are:
// chrome, chromium, edge, electron, firefox, nwjs, opera, safari
OPTIMAL_BROWSERS: [ 'chrome', 'chromium', 'firefox', 'nwjs', 'electron' ],
OPTIMAL_BROWSERS: [ 'chrome', 'chromium', 'nwjs', 'electron' ],
// Browsers, in addition to those which do not fully support WebRTC, that
// are not supported and should show the unsupported browser page.

Loading…
Cancel
Save