Browse Source

Install the puppetlabs puppet package

in Ica34b7525bab53f8a6d161401f7fb9a2dbe37bc3 we added support for
installing puppet5 on bionic nodes.  However we missed adding the
package name.  Which results in the expansion[1]:

  apt-get --option Dpkg::Options::=--force-confold --assume-yes install -y --force-yes git rubygems

and later puppet isn't installed[2]:

  Failed to stop puppet.service: Unit puppet.service not loaded.

Adding the pkg name gets us[3]

[1] http://logs.openstack.org/41/588441/1/check/build-wheel-mirror-ubuntu-bionic/b3fd7ef/job-output.txt.gz#_2018-08-22_23_42_42_196476
[2] http://logs.openstack.org/41/588441/1/check/build-wheel-mirror-ubuntu-bionic/b3fd7ef/job-output.txt.gz#_2018-08-22_23_42_46_453880
[3] http://paste.openstack.org/raw/728653/

Change-Id: Icbcf5268624a5ff75e0058f8a355881125cd5d79
changes/56/595456/1
Tony Breeds 1 year ago
parent
commit
da2f6457ce
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      install_puppet.sh

+ 1
- 0
install_puppet.sh View File

@@ -221,6 +221,7 @@ function setup_puppet_ubuntu {
FACTER_VERSION=3.*
elif [ "$PUPPET_VERSION" == "5" ] ; then
puppet_deb=puppet5-release-bionic.deb
puppetpkg=puppet-agent
PUPPET_VERSION=5.*
FACTER_VERSION=3.*
else


Loading…
Cancel
Save