Fix install-plugins role

install-plugins role didn't take into account upper
constraints when installing plugins, this review
fixes that.

Change-Id: I82d81aad7952ce9d03c42187e4ae957043f59397
changes/14/728114/3
Martin Kopec 2 years ago committed by Andreas Jaeger
parent c8a084937e
commit 6f8d69f403
  1. 1
      .zuul.yaml
  2. 6
      roles/install-plugins/tasks/main.yaml

@ -52,6 +52,7 @@
- openstack/devstack
- openstack/designate
- openstack/designate-tempest-plugin
- openstack/requirements
roles:
- zuul: openstack/python-tempestconf
- zuul: openstack/tempest

@ -6,7 +6,11 @@
- name: Install plugins
become: yes
command: tox -evenv-tempest -- pip install {{ item }}
command:
cmd: >
tox -evenv-tempest --
pip install {{ item }}
--constraint {{ ansible_user_dir }}/{{ zuul.projects['opendev.org/openstack/requirements'].src_dir }}/upper-constraints.txt
with_items: "{{ plugins_paths }}"
args:
chdir: "{{devstack_base_dir}}/tempest"

Loading…
Cancel
Save