Browse Source

Switch to newer openstackdocstheme and reno versions

Switch to openstackdocstheme 2.2.0 and reno 3.1.0 versions. Using
these versions will allow especially:
* Linking from HTML to PDF document
* Allow parallel building of documents
* Fix some rendering problems

Update Sphinx version as well.

Remove docs requirements from lower-constraints, they are not needed
during install or test but only for docs building.

openstackdocstheme renames some variables, so follow the renames
before the next release removes them. A couple of variables are also
not needed anymore, remove them.

Change-Id: I42b7a7d44fc50218f99f6106324945864b46d74f
changes/11/729111/1
Andreas Jaeger 2 years ago
parent
commit
e5f2ba7c7d
  1. 6
      doc/requirements.txt
  2. 5
      doc/source/conf.py
  3. 5
      releasenotes/source/conf.py

6
doc/requirements.txt

@ -1,4 +1,4 @@
openstackdocstheme>=1.20.0 # Apache-2.0
reno>=1.8.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
openstackdocstheme>=2.2.0 # Apache-2.0
reno>=3.1.0 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
sphinx-argparse>=0.2.2 # MIT

5
doc/source/conf.py

@ -27,9 +27,8 @@ extensions = [
html_theme = 'openstackdocs'
# openstackdocstheme options
repository_name = 'openstack/python-tempestconf'
bug_project = '912'
bug_tag = 'doc'
openstackdocs_repo_name = 'openstack/python-tempestconf'
openstackdocs_use_storyboard = True
# autodoc generation is a bit aggressive and a nuisance when doing heavy
# text edit cycles.

5
releasenotes/source/conf.py

@ -43,9 +43,8 @@ extensions = [
]
# openstackdocstheme options
repository_name = 'openstack/python-tempestconf'
bug_project = '912'
bug_tag = 'releasenotes'
openstackdocs_repo_name = 'openstack/python-tempestconf'
openstackdocs_use_storyboard = True
# Add any paths that contain templates here, relative to this directory.
templates_path = ['_templates']

Loading…
Cancel
Save