Browse Source

Add mandatory requires_ansible version to metadata

Disable ansible-test since it's broken in 2.11[1]

[1] https://github.com/ansible/ansible/issues/75353
Change-Id: Idd2f99ddfe507b5b02de206c1f8c75692d6a84a2
changes/59/802859/8 1.5.1-3
Sagi Shnaidman 2 months ago
parent
commit
07374a1f0d
  1. 6
      .zuul.yaml
  2. 1
      meta/runtime.yml

6
.zuul.yaml

@ -276,7 +276,7 @@
nodeset: ubuntu-bionic
description: |
Run openstack collections linter tests using the 2.11 branch of ansible
voting: true
voting: false
required-projects:
- name: github.com/ansible/ansible
override-checkout: stable-2.11
@ -370,7 +370,7 @@
dependencies: &deps_unit_lint
- tox-pep8
- openstack-tox-linters-ansible-2.9
- openstack-tox-linters-ansible-2.11
# - openstack-tox-linters-ansible-2.11
- ansible-collections-openstack-functional-devstack-releases:
dependencies: *deps_unit_lint
@ -413,7 +413,7 @@
gate:
jobs:
- tox-pep8
- openstack-tox-linters-ansible-2.11
# - openstack-tox-linters-ansible-2.11
- openstack-tox-linters-ansible-2.9
- ansible-collections-openstack-functional-devstack
- ansible-collections-openstack-functional-devstack-releases

1
meta/runtime.yml

@ -1,3 +1,4 @@
requires_ansible: ">=2.8"
action_groups:
openstack:
- address_scope

Loading…
Cancel
Save