Browse Source

Merge "Updated from OpenStack Ansible Tests"

master
Zuul 4 weeks ago
committed by Gerrit Code Review
parent
commit
59a80f9a44
3 changed files with 10 additions and 30 deletions
  1. +7
    -18
      Vagrantfile
  2. +2
    -5
      bindep.txt
  3. +1
    -7
      run_tests.sh

+ 7
- 18
Vagrantfile View File

@ -35,28 +35,17 @@ Vagrant.configure(2) do |config|
centos8.vm.box = "centos/8"
end
config.vm.define "debian8" do |debian8|
debian8.vm.box = "debian/jessie64"
end
config.vm.define "debian9" do |debian9|
debian9.vm.box = "debian/stretch64"
end
config.vm.define "gentoo" do |gentoo|
gentoo.vm.box = "generic/gentoo"
end
config.vm.define "opensuse150" do |leap150|
leap150.vm.box = "opensuse/openSUSE-15.0-x86_64"
end
config.vm.define "opensuse151" do |leap151|
leap151.vm.box = "opensuse/openSUSE-15.1-x86_64"
config.vm.define "debian10" do |debian10|
debian10.vm.box = "debian/buster64"
end
config.vm.define "ubuntu1804" do |bionic|
bionic.disksize.size = "40GB"
bionic.vm.box = "ubuntu/bionic64"
end
config.vm.define "ubuntu2004" do |focal|
focal.disksize.size = "40GB"
focal.vm.box = "ubuntu/focal64"
end
end

+ 2
- 5
bindep.txt View File

@ -26,7 +26,7 @@
gcc
# Base requirements for Ubuntu
git-core [platform:dpkg platform:suse]
git-core [platform:dpkg]
libssl-dev [platform:dpkg]
libffi-dev [platform:dpkg]
python3 [platform:dpkg]
@ -35,15 +35,12 @@ python3-dev [platform:dpkg]
# Base requirements for RPM distros
gcc-c++ [platform:rpm]
git [platform:rpm !platform:suse]
git [platform:rpm]
libffi-devel [platform:rpm]
openssl-devel [platform:rpm]
python3-dnf [platform:fedora]
python3-devel [platform:rpm]
# Base requirements for Gentoo
git [platform:gentoo]
# For SELinux
libselinux-python3 [platform:redhat]
libsemanage-python3 [platform:redhat]


+ 1
- 7
run_tests.sh View File

@ -53,19 +53,13 @@ source /etc/os-release || source /usr/lib/os-release
# Figure out the appropriate package install command
case ${ID,,} in
*suse*) pkg_mgr_cmd="zypper -n in" ;;
centos|rhel|fedora) pkg_mgr_cmd="dnf install -y" ;;
ubuntu|debian) pkg_mgr_cmd="apt-get install -y" ;;
# Gentoo needs to have version set since it's rolling
gentoo) pkg_mgr_cmd="emerge --jobs=4"; VERSION="rolling" ;;
*) echo "unsupported distribution: ${ID,,}"; exit 1 ;;
esac
# Install git so that we can clone the tests repo if git is not available
case ${ID,,} in
gentoo) which git &>/dev/null || eval sudo "${pkg_mgr_cmd}" dev-vcs/git ;;
*) which git &>/dev/null || eval sudo "${pkg_mgr_cmd}" git ;;
esac
which git &>/dev/null || eval sudo "${pkg_mgr_cmd}" git
# Clone the tests repo for access to the common test script
if [[ ! -d "${COMMON_TESTS_PATH}" ]]; then


Loading…
Cancel
Save