Browse Source

Merge "Replace ansible requirement by ansible-core"

changes/66/819266/9
Zuul 6 months ago committed by Gerrit Code Review
parent
commit
66c819423e
  1. 2
      docs/doc-requirements.txt
  2. 3
      requirements.txt
  3. 4
      tox.ini

2
docs/doc-requirements.txt

@ -2,4 +2,4 @@
sphinx>=1.1.2,!=1.2.0,!=1.3b1
oslosphinx>=2.2.0 # Apache-2.0
sphinx_rtd_theme==0.1.7
ansible
ansible-core>=2.11,<2.12

3
requirements.txt

@ -1,3 +1,2 @@
pbr>=1.6
# Do not remove 2.10, ansible-test and tox-ansible require it
ansible>=2.5,<2.11
ansible-core>=2.11,<2.12

4
tox.ini

@ -59,12 +59,12 @@ setenv =
# 2/3 molecule scenarios are expected to pass
PYTEST_REQPASS=2
deps =
ansible>=2.9,<2.10
ansible-core>=2.11,<2.12
molecule[test,docker]>=3.3.2,<3.4 # MIT
pytest-molecule>=1.4.0
pytest-plus # provides support for PYTEST_REQPASS
commands =
ansible-galaxy collection install community.docker
ansible-galaxy collection install --force community.docker:=1.10.0 community.general:=4.0.2
python -m pytest --color=yes --html={envlogdir}/reports.html --self-contained-html {tty:-s} -k molecule {posargs}
[testenv:ansible]

Loading…
Cancel
Save