Browse Source

Bump pyflakes and pin ansible-lint

We need a python 3.9 compatible version of pyflakes and we need to
pin ansible-lint to an ansible 2.7 compatible version.

Related PyCQA/pyflakes #367

Change-Id: Iedc76eb82d831cad8dfc569477eece827aca750c
changes/51/761951/3
Alex Schultz 5 months ago
parent
commit
0ccfeadc25
3 changed files with 2 additions and 2 deletions
  1. +1
    -1
      ansible-requirements.txt
  2. +0
    -1
      requirements.txt
  3. +1
    -0
      test-requirements.txt

+ 1
- 1
ansible-requirements.txt View File

@ -3,4 +3,4 @@
# lint checks and want to document these as ansible specific things that may
# be required for this repository.
ansible==2.7.6
ansible-lint
ansible-lint<=4.0.0

+ 0
- 1
requirements.txt View File

@ -1,2 +1 @@
pbr>=1.6
ansible

+ 1
- 0
test-requirements.txt View File

@ -1 +1,2 @@
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
pyflakes>=2.2.0

Loading…
Cancel
Save