Browse Source

Fix packages fact

Update packages fact variable to use ansible_facts.

Change-Id: I0039bf7c2dd11da212ad1f74bb227562af6c13cb
Related-Bug: #1915761
changes/67/789567/1 1.1.4
Alex Schultz 5 months ago
parent
commit
d70c205af8
  1. 4
      tasks/satellite-6.yml

4
tasks/satellite-6.yml

@ -7,7 +7,7 @@
assert:
fail_msg: The installed version of subscription-manager is too old.
that:
- packages['subscription-manager'][0]['version'] is version_compare('1.10', '>=')
- ansible_facts['packages']['subscription-manager'][0]['version'] is version_compare('1.10', '>=')
rescue:
- name: Attempt to update subscription-manager
yum:
@ -18,7 +18,7 @@
assert:
fail_msg: The installed version of subscription-manager is too old.
that:
- packages['subscription-manager'][0]['version'] is version_compare('1.10', '>=')
- ansible_facts['packages']['subscription-manager'][0]['version'] is version_compare('1.10', '>=')
- name: Configure yum plugins
ini_file:

Loading…
Cancel
Save