浏览代码

Use length to avoid unsupported operations with '>'

The dev_install.yaml script breaks when running python 3 because of
unsupported comparisions between 'AnsibleUnsafeText' and 'int' with the
'>' operator.

This is very similar to a bug opened against ansible upstream [0]. We
can fix the issue by using length explicitly, which ensures we're
comparing integers to integers since we're dealing with a list.

[0] https://github.com/ansible/ansible/issues/50388

Change-Id: I100639982b75c9d345269ba9bf10defb7e96d774
tags/1.2.0
Lance Bragstad 6 个月前
父节点
当前提交
970e479c48
共有 1 个文件被更改,包括 2 次插入2 次删除
  1. +2
    -2
      tasks/dev_install.yml

+ 2
- 2
tasks/dev_install.yml 查看文件

@@ -33,7 +33,7 @@
args:
chdir: "{{ modify_dir_path }}"
loop: "{{ refspecs }}"
when: item > 0
when: item | length > 0

- name: Copy the Python directories into local temp dir
command: "/bin/bash dev_install.sh {{ item }}"
@@ -42,6 +42,6 @@
args:
chdir: "{{ modify_dir_path }}"
loop: "{{ python_dir }}"
when: item > 0
when: item | length > 0

- include_tasks: modify_image.yml

正在加载...
取消
保存