Browse Source

Fix incompatible requirements

A lot of packages in lower-constraints.txt and requirement.txt
must change to suitable version. Which raised fail in following logs:

 Validating requirements.txt
 Validating test-requirements.txt
 Validating lower constraints of requirements.txt
 Package u'oslo.log' is constrained to 3.37.0 which does not match the minimum version specifier 3.36.0 in requirements.txt
 Package u'paramiko' is constrained to 2.4.1 which does not match the minimum version specifier 2.0.0 in requirements.txt
 Package u'setuptools' is used in requirements.txt but not in lower-constraints.txt
 Package u'pbr' is constrained to 3.1.1 which does not match the minimum version specifier 2.0.0 in requirements.txt
 Validating lower constraints of test-requirements.txt
 Package u'sphinx' is constrained to 1.6.5 which does not match the minimum version specifier 1.6.2 in test-requirements.txt
 Package u'coverage' is constrained to 4.5.1 which does not match the minimum version specifier 4.0 in test-requirements.txt
 Package u'oslotest' is constrained to 3.3.0 which does not match the minimum version specifier 3.2.0 in test-requirements.txt
 Package u'openstackdocstheme' is constrained to 1.20.0 which does not match the minimum version specifier 1.18.1 in test-requirements.txt
 Package u'doc8' is constrained to 0.8.0 which does not match the minimum version specifier 0.6.0 in test-requirements.txt
 Package u'reno' is constrained to 2.7.0 which does not match the minimum version specifier 2.5.0 in test-requirements.txt
 Package u'testrepository' is constrained to 0.0.20 which does not match the minimum version specifier 0.0.18 in test-requirements.txt
 Package u'testscenarios' is constrained to 0.5.0 which does not match the minimum version specifier 0.4 in test-requirements.txt
 Package u'testtools' is constrained to 2.3.0 which does not match the minimum version specifier 2.2.0 in test-requirements.txt
 *** Incompatible requirement found!
 *** See http://docs.openstack.org/developer/requirements
 ERROR
 {
   "delta": "0:00:09.290821",
   "end": "2018-05-23 16:24:17.040257",
   "failed": true,
   "rc": 1,
   "start": "2018-05-23 16:24:07.749436"
 }

Change-Id: I5bcc2b3523c30126e88c0396a3ea080a70bb66bd
tags/5.1.0
Nguyen Van Trung 1 year ago
parent
commit
fa4f095759
2 changed files with 13 additions and 12 deletions
  1. 12
    11
      lower-constraints.txt
  2. 1
    1
      test-requirements.txt

+ 12
- 11
lower-constraints.txt View File

@@ -6,10 +6,10 @@ bcrypt==3.1.4
6 6
 certifi==2018.1.18
7 7
 cffi==1.11.5
8 8
 chardet==3.0.4
9
-coverage==4.5.1
9
+coverage==4.0
10 10
 cryptography==2.1.4
11 11
 debtcollector==1.19.0
12
-doc8==0.8.0
12
+doc8==0.6.0
13 13
 docutils==0.14
14 14
 dulwich==0.19.0
15 15
 extras==1.0.0
@@ -30,19 +30,20 @@ mox3==0.25.0
30 30
 msgpack==0.5.6
31 31
 netaddr==0.7.19
32 32
 netifaces==0.10.6
33
-openstackdocstheme==1.20.0
33
+openstackdocstheme==1.18.1
34 34
 os-client-config==1.29.0
35 35
 oslo.config==5.2.0
36 36
 oslo.context==2.20.0
37 37
 oslo.i18n==3.20.0
38
-oslo.log==3.37.0
38
+oslo.log==3.36.0
39 39
 oslo.serialization==2.25.0
40 40
 oslo.utils==3.36.0
41
-oslotest==3.3.0
42
-paramiko==2.4.1
43
-pbr==3.1.1
41
+oslotest==3.2.0
42
+paramiko==2.0.0
43
+pbr==2.0.0
44 44
 pep8==1.5.7
45 45
 pyasn1==0.4.2
46
+setuptools===21.0.0
46 47
 pycparser==2.18
47 48
 pyflakes==0.8.1
48 49
 Pygments==2.2.0
@@ -54,7 +55,7 @@ python-mimeparse==1.6.0
54 55
 python-subunit==1.2.0
55 56
 pytz==2018.3
56 57
 PyYAML==3.12
57
-reno==2.7.0
58
+reno==2.5.0
58 59
 requests==2.18.4
59 60
 requestsexceptions==1.4.0
60 61
 restructuredtext-lint==1.1.3
@@ -64,9 +65,9 @@ snowballstemmer==1.2.1
64 65
 Sphinx==1.6.5
65 66
 sphinxcontrib-websupport==1.0.1
66 67
 stevedore==1.28.0
67
-testrepository==0.0.20
68
-testscenarios==0.5.0
69
-testtools==2.3.0
68
+testrepository==0.0.18
69
+testscenarios==0.4
70
+testtools==2.2.0
70 71
 traceback2==1.4.0
71 72
 unittest2==1.1.0
72 73
 urllib3==1.22

+ 1
- 1
test-requirements.txt View File

@@ -7,7 +7,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
7 7
 coverage!=4.4,>=4.0 # Apache-2.0
8 8
 doc8>=0.6.0 # Apache-2.0
9 9
 reno>=2.5.0 # Apache-2.0
10
-sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
10
+sphinx!=1.6.6,!=1.6.7,>=1.6.5 # BSD
11 11
 openstackdocstheme>=1.18.1 # Apache-2.0
12 12
 oslotest>=3.2.0 # Apache-2.0
13 13
 testrepository>=0.0.18 # Apache-2.0/BSD

Loading…
Cancel
Save