Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Update classifiers
- Update requirements, no need for python_version anymore

Change-Id: I051224a8a943bc0fe83cc507538d888aeff5af8d
changes/23/737223/1 victoria-em
Pierre Riteau 2 years ago
parent
commit
7aac164964
  1. 3
      setup.cfg
  2. 9
      setup.py
  3. 2
      test-requirements.txt

3
setup.cfg

@ -3,8 +3,11 @@ name = blazar-nova
summary = Nova related filters and extensions for Blazar
description-file = README.rst
license = Apache Software License
python-requires = >=3.6
classifiers =
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7

9
setup.py

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

2
test-requirements.txt

@ -6,7 +6,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
nose>=1.3.7 # LGPL
mock>=2.0.0 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinxcontrib-httpdomain>=1.3.0 # BSD
fixtures>=3.0.0 # Apache-2.0/BSD

Loading…
Cancel
Save