Browse Source

Merge "Sync requirements and lower-constraints with nova"

changes/59/834159/1 2.6.0
Zuul 6 months ago committed by Gerrit Code Review
parent
commit
dcc9858793
  1. 29
      lower-constraints.txt
  2. 6
      requirements.txt
  3. 2
      test-requirements.txt

29
lower-constraints.txt

@ -58,32 +58,32 @@ netifaces==0.10.4
networkx==2.1.0
numpy==1.19.0
openstacksdk==0.35.0
os-brick==4.3.1
os-brick==5.2
os-client-config==1.29.0
os-resource-classes==1.1.0
os-service-types==1.7.0
os-traits==2.5.0
os-traits==2.7.0
os-vif==1.15.2
os-win==5.4.0
os-xenapi==0.3.4
os-win==5.5.0
osc-lib==1.10.0
oslo.cache==1.26.0
oslo.concurrency==4.4.0
oslo.concurrency==4.5.0
oslo.config==8.6.0
oslo.context==3.1.1
oslo.context==3.4.0
oslo.db==10.0.0
oslo.i18n==5.0.1
oslo.log==4.4.0
oslo.i18n==5.1.0
oslo.log==4.6.1
oslo.limit==1.5.0
oslo.messaging==10.3.0
oslo.middleware==3.31.0
oslo.policy==3.7.0
oslo.privsep==2.4.0
oslo.privsep==2.6.2
oslo.reports==1.18.0
oslo.rootwrap==5.8.0
oslo.serialization==4.1.0
oslo.service==2.5.0
oslo.serialization==4.2.0
oslo.service==2.8.0
oslo.upgradecheck==1.3.0
oslo.utils==4.8.0
oslo.utils==4.12.1
oslo.versionedobjects==1.35.0
oslo.vmware==3.6.0
oslotest==3.8.0
@ -94,7 +94,7 @@ packaging==20.4
paramiko==2.7.1
Paste==2.0.2
PasteDeploy==1.5.0
pbr==5.5.1
pbr==5.8.0
pluggy==0.6.0
ply==3.11
prettytable==0.7.1
@ -134,6 +134,7 @@ retrying==1.3.3
rfc3986==1.2.0
Routes==2.3.1
simplejson==3.13.2
six==1.15.0
smmap2==2.0.3
sortedcontainers==2.1.0
SQLAlchemy==1.4.13
@ -149,7 +150,7 @@ tenacity==6.3.1
testrepository==0.0.20
testresources==2.0.0
testscenarios==0.4
testtools==2.2.0
testtools==2.5.0
tooz==1.58.0
traceback2==1.4.0
types-paramiko==0.1.3

6
requirements.txt

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=5.5.1 # Apache-2.0
pbr>=5.8.0 # Apache-2.0
oslo.config>=8.6.0 # Apache-2.0
oslo.i18n>=5.0.1 # Apache-2.0
oslo.log>=4.4.0 # Apache-2.0
oslo.i18n>=5.1.0 # Apache-2.0
oslo.log>=4.6.1 # Apache-2.0

2
test-requirements.txt

@ -8,7 +8,7 @@ mock>=3.0.0 # BSD
fixtures>=3.0.0 # Apache-2.0/BSD
stestr>=2.0.0 # Apache-2.0
testtools>=2.2.0 # MIT
testtools>=2.5.0 # MIT
coverage!=4.4,>=4.0 # Apache-2.0
wsgi-intercept>=1.7.0 # MIT License

Loading…
Cancel
Save