Browse Source

[stable-only] Add font for PDF generation and fix lower constraints

openstack-tox-docs job started to fail with the following error:

! LaTeX Error: File `tgtermes.sty' not found.

This patch adds the required font package to bindep doc profile.

With the new pip resolver (introduced in pip 20.3) the constraints
checking is now working better, thus reveals multiple constrain
conflicts. This patch also fixes those problems:
- no extra is allowed for constraints
- futurist 1.8.0 depends on six>=1.10.0
- keystoneauth1 3.9.0 depends on requests>=2.14.2
- oslo.upgradecheck==0.1.1 was not listed among lower constraints

Conflicts:
    lower-constraints.txt
    requirements.txt

Change-Id: I00c994316653446748823867eb7c1a1ba5abfbea
(cherry picked from commit 418af55c7b)
(cherry picked from commit ea7014ba6d)
changes/73/794973/1
Elod Illes 1 week ago
parent
commit
1d2abc85a4
3 changed files with 9 additions and 6 deletions
  1. +3
    -0
      bindep.txt
  2. +4
    -4
      lower-constraints.txt
  3. +2
    -2
      requirements.txt

+ 3
- 0
bindep.txt View File

@ -5,3 +5,6 @@ build-essential [platform:dpkg]
libffi-dev [platform:dpkg]
gettext [platform:dpkg]
python37 [platform:rpm py37]
# PDF Docs package dependencies
tex-gyre [platform:dpkg doc]

+ 4
- 4
lower-constraints.txt View File

@ -20,10 +20,10 @@ oslo.config==5.2.0
oslo.i18n==3.15.3
oslo.log==3.36.0
oslo.messaging==6.2.0
oslo.messaging[kafka]==6.2.0
oslo.privsep==1.32.0
oslo.reports==1.18.0
oslo.rootwrap==2.0.0
oslo.upgradecheck==0.1.1
oslo.utils==3.37.0
oslo.vmware==2.17.0
oslotest==3.2.0
@ -38,12 +38,12 @@ python-novaclient==9.1.0
python-swiftclient==3.2.0
python-zaqarclient==1.3.0
PyYAML==3.12
requests==2.8.1
requests==2.14.2
requests-aws==0.1.4
six==1.9.0
six==1.10.0
stestr==2.0.0
stevedore==1.20.0
tenacity==4.4.0
testscenarios==0.4
testtools==2.2.0
tooz[zake]==1.47.0
tooz==1.47.0

+ 2
- 2
requirements.txt View File

@ -30,8 +30,8 @@ python-novaclient>=9.1.0 # Apache-2.0
python-swiftclient>=3.2.0 # Apache-2.0
python-cinderclient>=3.3.0 # Apache-2.0
PyYAML>=3.12 # MIT
requests!=2.9.0,>=2.8.1 # Apache-2.0
six>=1.9.0 # MIT
requests>=2.14.2 # Apache-2.0
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0
tenacity>=4.4.0 # Apache-2.0
tooz[zake]>=1.47.0 # Apache-2.0


Loading…
Cancel
Save