Browse Source

[stable-only] Cap msgpack

periodic job py27 started to fail with:
TypeError: __init__() got an unexpected keyword argument 'encoding'

This failure comes with the new version of msgpack (1.0.0).

Since ceilometer does not use global upper-constraints.txt from
requirements repository, msgpack has to be constrained in
requirements.txt

Change-Id: I3ca76c80b96d49d4d256110c8fca13f9365add0d
(cherry picked from commit f63a65acc0)
(cherry picked from commit 9923f27d24)
changes/62/708662/1
Elod Illes 4 months ago
parent
commit
273f66b8fc
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      requirements.txt

+ 1
- 1
requirements.txt View File

@@ -10,7 +10,7 @@ debtcollector>=1.2.0 # Apache-2.0
jsonpath-rw-ext>=0.1.9 # Apache-2.0
lxml>=2.3 # BSD
monotonic
msgpack>=0.4.0 # Apache-2.0
msgpack>=0.4.0,<1.0.0 # Apache-2.0
oslo.concurrency>=3.5.0 # Apache-2.0
oslo.config>=3.22.0 # Apache-2.0
oslo.i18n>=2.1.0 # Apache-2.0


Loading…
Cancel
Save