Switch to newer openstackdocstheme version

Switch to openstackdocstheme 2.2.1 version. Using
this version will allow especially:
* Linking from HTML to PDF document
* Allow parallel building of documents
* Fix some rendering problems

Update Sphinx version as well.

openstackdocstheme renames some variables, so follow the renames
before the next release removes them. A couple of variables are also
not needed anymore, remove them.

See also
http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014971.html

Change-Id: I666adb3c053b914d81790c56e08fd2ce9f6a7d1a
changes/48/732048/1
Andreas Jaeger 2 years ago
parent f862377de0
commit cb2f8a3e75
  1. 6
      deploy-guide/source/conf.py
  2. 4
      requirements.txt

@ -54,9 +54,9 @@ master_doc = 'index'
copyright = u'2016, OpenStack contributors'
# Settings for openstackdocstheme
repository_name = 'openstack/charm-deployment-guide'
bug_project = 'charm-deployment-guide'
bug_tag = u'deployment-guide'
openstackdocs_repo_name = 'openstack/charm-deployment-guide'
openstackdocs_bug_project = 'charm-deployment-guide'
openstackdocs_bug_tag = u'deployment-guide'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the

@ -4,5 +4,5 @@
pbr!=2.1.0,>=2.0.0 # Apache-2.0
sphinx>=1.8.0,!=2.1.0 # BSD
openstackdocstheme>=1.30.0 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.2.1 # Apache-2.0

Loading…
Cancel
Save