Browse Source

Add py36 testenv

Python 3.6 is installed by default in Ubuntu 18.04 LTS.
Therefore, according to Transition Plan [1],
it'll be handy to have py36 testenv.

For more details, please check Python2 Deprecation Timeline [2]
and Python3-first Goal - Completion Criteria [3].

[1] https://wiki.ubuntu.com/Python/Python36Transition
[2] https://governance.openstack.org/tc/resolutions/20180529-python2-deprecation-timeline.html
[3] https://review.openstack.org/#/c/575933/8/goals/stein/python3-first.rst@42

Change-Id: I5f46c652dbc988991b2d506d66a985de7e5af8c9
changes/24/585324/1
melissaml 11 months ago
parent
commit
954f1dc815
1 changed files with 5 additions and 0 deletions
  1. 5
    0
      tox.ini

+ 5
- 0
tox.ini View File

@@ -15,6 +15,11 @@ basepython = python3
15 15
 deps = -r{toxinidir}/test-requirements.txt
16 16
 commands = ostestr {posargs}
17 17
 
18
+[testenv:py36]
19
+basepython = python3.6
20
+deps = -r{toxinidir}/test-requirements.txt
21
+commands = ostestr {posargs}
22
+
18 23
 [testenv:pep8]
19 24
 basepython = python2.7
20 25
 deps = -r{toxinidir}/test-requirements.txt

Loading…
Cancel
Save