Browse Source

Add yoga bundles and release-tool syncs

* charm-helpers sync for classic charms
* sync from release-tools
* switch to release-specific zosci functional tests
* run focal-ussuri as smoke tests
* remove trusty, xenial, and groovy metadata/tests
* drop py35 and add py39

Change-Id: Ia2e35ead4afa35df7a19869b96ee41c6ec6c4d65
changes/37/816037/9
Corey Bryant 7 months ago
parent
commit
6df44f9506
  1. 18
      osci.yaml
  2. 1
      requirements.txt
  3. 1
      src/tests/bundles/groovy-full-ha.yaml
  4. 1
      src/tests/bundles/jammy-full-ha.yaml
  5. 2
      src/tests/bundles/jammy-full.yaml
  6. 2
      src/tests/bundles/jammy.yaml
  7. 0
      src/tests/bundles/overlays/jammy-full-ha.yaml.j2
  8. 17
      src/tests/tests.yaml
  9. 2
      test-requirements.txt
  10. 5
      tox.ini

18
osci.yaml

@ -1,16 +1,20 @@
- project:
templates:
- charm-unit-jobs
- charm-yoga-unit-jobs
check:
jobs:
- focal
- hirsute
- impish:
voting: false
- jammy:
voting: false
- full_model_ha-focal-full-ha
- full_model_ha-hirsute-full-ha
- full_model_ha-impish-full-ha:
voting: false
- full_model_ha-jammy-full-ha:
voting: false
vars:
needs_charm_build: true
charm_build_name: mysql-router
@ -23,23 +27,23 @@
vars:
tox_extra_args: full_model_ha:focal-full-ha
- job:
name: full_model_ha-groovy-full-ha
name: full_model_ha-hirsute-full-ha
parent: func-target
dependencies:
- focal
vars:
tox_extra_args: full_model_ha:groovy-full-ha
tox_extra_args: full_model_ha:hirsute-full-ha
- job:
name: full_model_ha-hirsute-full-ha
name: full_model_ha-impish-full-ha
parent: func-target
dependencies:
- focal
vars:
tox_extra_args: full_model_ha:hirsute-full-ha
tox_extra_args: full_model_ha:impish-full-ha
- job:
name: full_model_ha-impish-full-ha
name: full_model_ha-jammy-full-ha
parent: func-target
dependencies:
- focal
vars:
tox_extra_args: full_model_ha:impish-full-ha
tox_extra_args: full_model_ha:jammy-full-ha

1
requirements.txt

@ -9,6 +9,7 @@
setuptools<50.0.0 # https://github.com/pypa/setuptools/commit/04e3df22df840c6bb244e9b27bc56750c44b7c85
# Build requirements
cffi==1.14.6; python_version < '3.6' # cffi 1.15.0 drops support for py35.
charm-tools==2.8.3
simplejson

1
src/tests/bundles/groovy-full-ha.yaml

@ -1 +0,0 @@
groovy-full.yaml

1
src/tests/bundles/jammy-full-ha.yaml

@ -0,0 +1 @@
jammy-full.yaml

2
src/tests/bundles/groovy-full.yaml → src/tests/bundles/jammy-full.yaml

@ -1,7 +1,7 @@
variables:
openstack-origin: &openstack-origin distro
series: &series groovy
series: &series jammy
applications:
keystone-mysql-router:

2
src/tests/bundles/groovy.yaml → src/tests/bundles/jammy.yaml

@ -1,4 +1,4 @@
series: groovy
series: jammy
applications:
keystone-mysql-router:
charm: ../../../mysql-router

0
src/tests/bundles/overlays/groovy-full-ha.yaml.j2 → src/tests/bundles/overlays/jammy-full-ha.yaml.j2

17
src/tests/tests.yaml

@ -23,27 +23,26 @@ tests:
gate_bundles:
- full_model_ha: focal-full-ha
dev_bundles:
- groovy
- full_model_ha: groovy-full-ha
- hirsute
- full_model_ha: hirsute-full-ha
- impish
- full_model_ha: impish-full-ha
dev_bundles:
- full_model_ha: jammy-full-ha
smoke_bundles:
- focal
- full_model_ha: focal-full-ha
tests_options:
hacluster:
principle-app-name: keystone
hacluster-charm-name: hacluster
force_deploy:
- groovy
- groovy-full-ha
- hirsute
- hirsute-full-ha
- impish
- impish-full-ha
- jammy
- jammy-full-ha
target_deploy_status:
neutron-api-plugin-ovn:

2
test-requirements.txt

@ -3,6 +3,8 @@
# choices of *requirements.txt files for OpenStack Charms:
# https://github.com/openstack-charmers/release-tools
#
pyparsing<3.0.0 # aodhclient is pinned in zaza and needs pyparsing < 3.0.0, but cffi also needs it, so pin here.
cffi==1.14.6; python_version < '3.6' # cffi 1.15.0 drops support for py35.
setuptools<50.0.0 # https://github.com/pypa/setuptools/commit/04e3df22df840c6bb244e9b27bc56750c44b7c85
stestr>=2.2.0

5
tox.ini

@ -75,6 +75,11 @@ basepython = python3.8
deps = -r{toxinidir}/test-requirements.txt
commands = stestr run --slowest {posargs}
[testenv:py39]
basepython = python3.9
deps = -r{toxinidir}/test-requirements.txt
commands = stestr run --slowest {posargs}
[testenv:pep8]
basepython = python3
deps = flake8==3.9.2

Loading…
Cancel
Save