Commit Graph

69 Commits (master)

Author SHA1 Message Date
Corey Bryant ddf5ff8a3b Add 2023.2 Bobcat support
* sync charm-helpers to classic charms
* change openstack-origin/source default to bobcat
* add mantic to metadata series
* align testing with bobcat
* add new bobcat bundles
* add bobcat bundles to tests.yaml
* add bobcat tests to osci.yaml
* update build-on and run-on bases
* drop kinetic
* update charmcraft_channel to 2.x/edge

Change-Id: Ibb10bdf41174601af3a2145f3802c48586c44878
2023-08-03 13:59:56 -04:00
Martin Kalcok 63adc21543 Signal Neutron service restart on OVN upgrade
Notify principal charm to restart Neutron service
after OVN package upgrade

Change-Id: Iedb9985ae448a7149029168a361e574a41b7ad29
2023-07-13 13:28:18 +02:00
Zuul 9d0cb6f505 Merge "Enable ovn_emit_need_to_frag" 2023-07-10 13:58:54 +00:00
Yamen Hatahet c26114ddd8 Enable ovn_emit_need_to_frag
Enabled by default since this branch only supports jammy where the
kernel and ovn are new enough to support this flag. This will eliminate
the need for a more complex change or the use of a dedicated opt-in
config option.

For more details, please refer to
I089f95b40803a6cd5e01990acacd599ced3bbd91

Closes-Bug: #1947391
Change-Id: Icc05980b4bc9184ba4e52722c6c11abfcfc0d58c
2023-07-04 10:15:19 +00:00
Martin Kalcok 412885acc9 Add 'ovn-source' config option.
This option enables configuration of overlay package
repository for installation of OVN packages that are
not available in default distribution repository.

Expected behavior:
* New deployments will use default overlay for
  their series.
* Setting this option to "distro" allows new
  deployment that does not use overlay repository
* Existing deployments that are upgraded to this
  version of the charm won't automatically apply
  repository overlay and will keep using their
  current defaults.

Closes-Bug: #1992770
Change-Id: I20789f637c9443bd274df5f91522f9e2ce973164
2023-07-03 18:49:39 +02:00
Dmytro Kazantsev 84ec4ada23 It sets “restart-trigger” key on neutron-plugin relation on upgrade-charm event.
When neutron-api-plugin-ovn charm is upgraded (juju refresh ...) some configuration parameters in ml2_conf.ini may have also updated.
It was observed that sometime those changes are not taken in to account by neutron service because it was not restarted after file content modification.
This change introduces rising of “restart-trigger” key on neutron-plugin relation databag when upgrade-charm event is generated.
With every new “charm-upgrade” event value for “restart-trigger” is updated: f.e. “restart-trigger cf2697c8-f5f0-44b5-8dae-32d893fb209c”.
Principal charm “neutron-api” has implemented logic which triggers neutron service restart as soon as “restart-trigger” key value is changed.

Closes-Bug: #2019798
Change-Id: Ia1f48d86330d6e357ae3b35ce28bbb036788ac4a
2023-06-29 11:14:00 +02:00
Dmitrii Shcherbakov 26287e88fd Enable neutron-dynamic-routing service plugin
Upstream Neutron has declared that the neutron-dynamic-routing service
plugin is now supported when OVN L3 service plugin and mechanism driver
are in use.

https://review.opendev.org/c/openstack/neutron/+/864051
4d1a7bd0bc

This change removes the NDR plugin from the filter so that the plugin
is enabled.

Change-Id: Ic101d8c9fd7a674103ea53fe0b56d3c3f315595c
2023-05-25 14:27:10 +00:00
Alex Kavanagh 3fc51fadd8 Convert to binary reactive charm (source charm fails to install)
Due to new install dependencies for urllib3, this charm has been
converted to a binary charm so that the build dependencies are resolved
at charm build, rather than charm install.

Note: the 23.04 binary charm build fails due to missing support in
charmcraft [1], but this should be addressed soon.

[1] https://github.com/canonical/charmcraft/issues/1104

Closes-Bug: #2019540
Change-Id: I0834ddf7d63bf7f7d59a122bc07f007abffb5f3f
2023-05-23 15:44:35 +01:00
Corey Bryant bd6cb347c5 Enable jammy-antelope voting and drop kinetic-zed tests
* Voting was turned on for jammy-antelope in the
  project-template for charm-functional-jobs in zosci-config
* Voting for jammy-antelope bundles with non-standard names
  is turned on in individual charms
* Kinetic-zed bundles/tests are removed
* Add libpython3-dev to allow the charm to be built. This
  fixes a missing dependency with Cython
* Remove wheelhouse pin of flit_core to avoid install hook
  failure.
* Rename overlay file to local-charm-overlay.yaml.j2 to avoid
  need for release-sepcific symlink overlay files.

Change-Id: I14ec64542f3a51adf9b32c6c2687023762f3210d
2023-04-19 19:02:21 +00:00
Corey Bryant 9acda0f1d1 Add Antelope support
* sync charm-helpers to classic charms
* change openstack-origin/source default to antelope
* align testing with antelope
* add new antelope bundles
* add antelope bundles to tests.yaml
* add antelope tests to osci.yaml and .zuul.yaml
* update build-on and run-on bases

Change-Id: I7c47fdaebb6e53cddda14ca78e0285123c94e291
2023-03-07 23:34:06 +00:00
Liam Young d621684020 Fix charm for tox4 compatibility
Related-Bug: 2002788
Change-Id: I9a1d1e92e491ea3b0857893d1c66247ab927c616
2023-01-18 17:22:15 +00:00
Felipe Reyes 01fdecd7c5 Add missing overlays
Changes:
- Add jammy-zed.yaml.j2
- Add kinetic-zed.yaml.j2
- Drop unused overlays (symlinks to ha.j2)
- Drop 'source' key from mysql-innodb-cluster and rabbitmq-server

Change-Id: I566431adce5fa0823247b10e2828f4f7e961faa6
2022-10-28 15:42:11 -03:00
jneo8 25a1d34a3b Fix wheelhouse missing dependency
Add poetry-core & flit_core in wheelhouse.txt to fix install hook error

Closes-bug: #1989669
Change-Id: Ie0865e21b224a5eb4445079c112b212ea48e45be
2022-09-15 16:14:56 +00:00
Corey Bryant 564d89ec90 Add Kinetic and Zed support
* sync charm-helpers to classic charms
* change openstack-origin/source default to zed
* align testing with zed
* add new zed bundles
* add zed bundles to tests.yaml
* add zed tests to osci.yaml and .zuul.yaml
* update build-on and run-on bases
* add bindep.txt for py310
* sync tox.ini and requirements.txt for ruamel
* use charmcraft_channel 2.0/stable
* drop reactive plugin overrides
* move interface/layer env vars to charmcraft.yaml

Change-Id: I3cc0af8443ecf62589c88d4e924cb633c419e87f
2022-08-31 20:22:25 +01:00
Zuul f67c9b7ba5 Merge "Fix offline network migration for sqlalchemy 1.4+" 2022-05-31 22:09:41 +00:00
Alex Kavanagh 7785c5b87d Add *.charm to gitignore
This patch adds *.charm to the .gitignore to ensure that any built
artifacts are ignored.

Change-Id: I78e4174155436bfe00ba6a2093be1c9e9223548f
2022-04-18 21:08:49 +01:00
Billy Olsen d20fda9b17 Fix offline network migration for sqlalchemy 1.4+
Sqlalchemy 1.4 dropped support for RowProxy and Row now behaves like a
tuple. This causes row and column iteration to fail using the RowProxy
semantics as the iteration methods are no longer there. Fix this by
checking which method needs to be used. This is necessary for backwards
compatibility with the Xena release for the Yoga branch.

Closes-Bug: #1968647
Change-Id: I6a4adbd87bd59ad3a4b0a8cef187d82f4e128084
2022-04-12 13:09:46 -07:00
Alex Kavanagh 8109de7d88 Updates to enable jammy and finalise charmcraft builds
- Add 22.04 to charmcraft.yaml
- Update metadata to include jammy
- Remove impish from metadata
- Update osci.yaml to include py3.10 default job
- Modify tox.ini to remove py35,py36,py37 tox target and add py310
  target.
- ensure that the openstack-origin is yoga

Change-Id: I064f4d30c4df8c5004cd30139dbed61d7775d19a
2022-04-04 15:51:09 +01:00
Alex Kavanagh 886c2ea713 Update to build using charmcraft
Due to a build problem with the reactive plugin, this change falls back
on overriding the steps and doing a manual build, but it also ensures
the CI system builds the charm using charmcraft.  Changes:

- add a build-requirements.txt
- modify charmcraft.yaml
- modify osci.yaml
    -> indicate build with charmcraft
- modify tox.ini
    -> tox -e build does charmcraft build/rename
    -> tox -e build-reactive does the reactive build
- modify bundles to use the <charm>.charm artifact in tests.
  and fix deprecation warning re: prefix
- tox inception to enable tox -e func-test in the CI

Change-Id: Icad049b5d152306be943c9c7177bbf751b48ddb0
2022-02-01 20:47:18 +00:00
Hervé Beraud 09e5ddc8d0 Use unittest.mock instead of mock
The mock third party library was needed for mock support in py2
runtimes. Since we now only support py36 and later, we can use the
standard lib unittest.mock module instead.

Note that https://github.com/openstack/charms.openstack is used during tests
and he need `mock`, unfortunatelly it doesn't declare `mock` in its
requirements so it retrieve mock from other charm project (cross dependency).
So we depend on charms.openstack first and when
Ib1ed5b598a52375e29e247db9ab4786df5b6d142 will be merged then CI
will pass without errors.

Depends-On: Ib1ed5b598a52375e29e247db9ab4786df5b6d142
Change-Id: I62e4e03f73db6e4ddd10b8d221a2ae8fda0a4290
2021-12-15 09:32:59 +00:00
Corey Bryant 240cc667a2 Add yoga bundles and release-tool syncs
* charm-helpers sync for classic charms
* sync from release-tools
* switch to release-specific zosci functional tests
* run focal-ussuri as smoke tests
* remove trusty, xenial, and groovy metadata/tests
* drop py35 and add py39

Change-Id: I94aced6559e0e354b8042b5728e4cb756082de1b
2021-11-19 11:23:29 -05:00
Corey Bryant 68e9c7586a Pin importlib_metadata in wheelhouse
This fixes an install hook failure caused by a conflict
between setuptools 41.6.0 and importlib_metadata by pinning
importlib_metadata to the last version that supported that
version of setuptools.

Closes-Bug: #1948967
Change-Id: Ic8376be8f1ef157dbfa13bd34ba51389cc472bb9
2021-11-19 16:02:55 +00:00
Corey Bryant 73abef5bba Pin cffi 1.14.6
Pin in requirements.txt used in charm build for py35 compatability.

Change-Id: If193493045869471a0a9186cfa3ba3c6f8856a7f
2021-11-19 15:29:19 +00:00
Alex Kavanagh a676eb9d90 Add xena bundles
- add non-voting focal-xena bundle
- add non-voting impish-xena bundle
- rebuild to pick up charm-helpers changes
- update tox/pip.sh to ensure setuptools<50.0.0

Change-Id: I1274fce02d5d9e0364c7dc8c02ca890714471529
2021-09-27 15:29:16 +01:00
Aurelien Lourot 58ca3bd83d Sync release-tools
In order to fix ResolutionImpossible on tox invocation.

https://github.com/openstack-charmers/release-tools/issues/151
https://github.com/openstack-charmers/release-tools/pull/152

Change-Id: I92c4ec300eae68bfaecb3e12df2fca076981f6bd
2021-07-22 14:58:03 +02:00
Zuul c78ae6f8f3 Merge "Add impish to metadata.yaml" 2021-06-24 12:14:46 +00:00
Aurelien Lourot e2794bb2b1 Add impish to metadata.yaml
Change-Id: Ib0494ac2cd02992c0d5b9d5a474f245906844fae
2021-06-03 11:20:18 +02:00
Corey Bryant 15e6453a5b rebuild - restore c-h proxy env vars for add-apt-repository
Change-Id: I0ce4cd8fd63b507a3bc8fd2cc2fafbc3aa63050c
2021-05-13 09:11:42 -04:00
Chris MacNaughton 6183b4c408 Test bundles for focal-wallaby and hirsute-wallaby
These are the test bundles (and any associated changes) for
focal-wallaby and hirsute-wallaby support.

hisute-wallaby test is disabled (moved to dev) due to [1].

[1] https://github.com/juju-solutions/layer-basic/issues/194

Change-Id: I53c243eac27a21948cc60b9f11125faec3f3ec36
2021-05-06 10:23:31 +00:00
Alex Kavanagh 51cb5626fa Updates to flip all libraries back to master
This patchset updates all the requirements for charms.openstack,
charm-helpers, charms.ceph, zaza and zaza-openstack-tests back
to master branch.

Change-Id: I3fdd311848691e01d8e78d68cf2091628a2447f8
2021-05-03 16:08:22 +01:00
Alex Kavanagh 977b6079eb 21.04 libraries freeze for charms on master branch
* charm-helpers sync for classic charms
* build.lock file for reactive charms
* ensure tox.ini is from release-tools
* ensure requirements.txt files are from release-tools
* On reactive charms:
  - ensure stable/21.04 branch for charms.openstack
  - ensure stable/21.04 branch for charm-helpers

Change-Id: Ie9ddc1992ba988f1b75ea92f686ed485effd610f
2021-04-08 14:49:05 +00:00
Zuul ce371e26fb Merge "Add new osci.yaml" 2021-03-19 11:19:02 +00:00
Chris MacNaughton df35caed86 Add new osci.yaml
This change is preparatory to migration Ubuntu OpenStack CI
from Jenkins to Zuul

Change-Id: I996496c12e189257a27fdb39dd094ccb0a6df929
2021-03-18 16:38:42 +01:00
Alex Kavanagh 42c75d44c5 Add hirsute and remove trusty from metadata.yaml
This update adds the new hirsute Ubuntu release (21.04) and
removes trusty support (14.04 which is EOL at 21.04).

Change-Id: I28a12f26e11bcd619318df176c9279c4326026e9
2021-03-02 21:00:38 +00:00
Alex Kavanagh 07678d021d Updates to pin charm-tools to 2.8.3
* Update requirements.txt to pin charm-tools to 2.8.3
* Update tox.ini to change the build parameters.
* This upgrades from <2.7 which adds reproducible charms
* Bug was fixed that controlled the default output directory
  doesn't get 'builds' appended.  The tox change puts it
  back so that stable & master both build to the same
  directory.  This may be reviewed in the future.

Change-Id: Ib87fe046bac26dabc915f14ce8651daa63deecce
2021-02-17 12:15:02 +00:00
Alex Kavanagh cfbe5d5972 Rebuild to use charm-tools pre 2.8 release
Reverting to an earlier version of charm-tools to
resolve some building issues seen with latest 2.8.2
version.

Change-Id: I633253f9660087cd988c02c6d74c4a615b58162f
2021-02-02 17:11:18 +00:00
David Ames 242be0bbe4 Rebuild with udpated charm-tools 2.8.2
Validate the newest version of charm-tools: 2.8.2
https://github.com/juju/charm-tools/pull/598

Change-Id: Iaec72a270691c6ba8ed3c8113a868ccd3c565678
2021-02-01 14:10:40 -08:00
Alex Kavanagh 9ea642b703 Updates for testing period for 20.01 release
Includes updates to charmhelpers/charms.openstack for cert_utils
and unit-get for the install hook error on Juju 2.9

* charm-helpers sync for classic charms
* rebuild for reactive charms
* ensure tox.ini is from release-tools
* ensure requirements.txt files are from release-tools
* On reactive charms:
  - ensure master branch for charms.openstack
  - ensure master branch for charm-helpers

Change-Id: I064d38d207b6dc6e7c8fd64facb2105f88ea23ce
2021-01-15 16:32:40 +00:00
Aurelien Lourot 1e5cc31214 Remove Disco and Eoan bits
Change-Id: I009f2818d4750aae6b8d43ddfcf2f55b10b55ff0
2021-01-12 14:00:02 +01:00
Aurelien Lourot 08fdfb686e Sync release-tools
Sync release-tools boilerplate containing these changes
in order to pin pip < 20.3:
https://github.com/openstack-charmers/release-tools/pull/125
https://github.com/openstack-charmers/release-tools/pull/126

Change-Id: I074ff16379c315e80efd9a29c319a4434ab5826e
2020-12-11 14:00:45 +01:00
Aurelien Lourot 06a53a62c6 Add Groovy to the test gate
Change-Id: Ie420f21333280de95799538fd733fbbf69b677e7
2020-11-05 12:50:46 +01:00
Alex Kavanagh bfc47e1dec Rebuild reactive charms to pick up latest charm-helpers release.
v0.20.18 has been released and needs incorporating into the reactive charms.

Change-Id: I73e633d8682dd4e91a98687bb71d36bb4448b6ae
2020-10-14 16:34:58 +01:00
Alex Kavanagh 744b5759e9 Sync libraries & common files prior to freeze
* charm-helpers sync for classic charms
* charms.ceph sync for ceph charms
* rebuild for reactive charms
* sync tox.ini files as needed
* sync requirements.txt files to sync to standard

Change-Id: I9c96f6170e1ff0ac123bccc6fe3faf7a576e5a7b
2020-09-26 18:36:19 +01:00
Frode Nordahl a3c846cdd2 Use correct row name for GRE tunnel id
The offline network type migration script used incorrect row name
for GRE tunnels.

Change-Id: I2ac9bd3416f1af61e99963c9fdc3191c29a2bb23
2020-09-09 08:33:28 +02:00
Zuul ec9384626f Merge "Add focal-victoria to the test gate" 2020-09-08 11:13:31 +00:00
Aurelien Lourot 28072cd61f Add focal-victoria to the test gate
Change-Id: I7c512893b987539268a570a7420356ea3e241031
2020-09-07 16:10:50 +02:00
Frode Nordahl 65f3911948
Add OVS to OVN migration actions
Switch smoke to focal-ussuri.

Unpin flake8.

Change-Id: Ifa99988612eaaeb9d60a0d99db172f97e27cfc93
2020-09-07 14:53:35 +02:00
Alex Kavanagh 4751846159 Release sync for 20.08
- Classic charms: sync charm-helpers.
- Classic ceph based charms:  also sync charms.ceph
- Reactive charms: trigger a rebuild
- sync tox.ini
- sync requirements.txt and test-requirements.txt

Change-Id: I6f5b40ed335db16d112d0b7db93c43405df425ed
2020-07-27 20:55:47 +01:00
Aurelien Lourot e9967a6755 Add Victoria test bundles
Change-Id: I4cc4b1f10e4bfc9f2a19c3782d826328d59a97c8
2020-07-27 11:12:45 +02:00
Alex Kavanagh 616bf06230 Updates for 20.08 cycle start for groovy and libs
- Adds groovy to the series in the metadata
- Classic charms: sync charm-helpers.
- Classic ceph based charms:  also sync charms.ceph
- Reactive charms: trigger a rebuild

Change-Id: I7706cdb03ec16319987c75c40e00c279853fa6b8
2020-07-23 17:44:08 +00:00