Browse Source

[stable-only] Pin virtualenv and setuptools

Setuptools 58.0 (bundled in virtualenv 20.8) breaks the installation of
decorator 3.4.0. So this patch pins virtualenv to avoid the break.
As the used 'require' feature was introduced in tox in version 3.2 [1],
the required minversion has to be bumped, too.

[1] https://tox.readthedocs.io/en/latest/config.html#conf-requires

Change-Id: I56d48ae312730c9023ebd5b87a9e5afb8cb694cc
changes/38/821738/1
Emilien Macchi 5 months ago
parent
commit
0fb7229979
  1. 6
      tox.ini

6
tox.ini

@ -1,8 +1,12 @@
[tox]
minversion = 2.5
minversion = 3.2.0
skipsdist = True
skip_missing_interpreters = true
envlist = py37,py27,compliance,pep8
# Pin the virtualenv and therefore the setuptools version used for the env
# creation. This results in a new tox being installed in .tox/.tox virtualenv
# and the tox on the host will delegate all the calls to the tox in that env.
requires = virtualenv<20.8
[testenv]
setenv = VIRTUAL_ENV={envdir}

Loading…
Cancel
Save