Browse Source

Merge "PowerMax Ussuri Driver - Setting the minimum version of U4P" into stable/ussuri

changes/81/742581/1
Zuul 3 weeks ago
committed by Gerrit Code Review
parent
commit
51bc4a903e
3 changed files with 3 additions and 3 deletions
  1. +1
    -1
      cinder/tests/unit/volume/drivers/dell_emc/powermax/powermax_data.py
  2. +1
    -1
      cinder/tests/unit/volume/drivers/dell_emc/powermax/test_powermax_rest.py
  3. +1
    -1
      cinder/volume/drivers/dell_emc/powermax/rest.py

+ 1
- 1
cinder/tests/unit/volume/drivers/dell_emc/powermax/powermax_data.py View File

@@ -1274,7 +1274,7 @@ class PowerMaxData(object):

data_dict = {volume_id: volume_info_dict}
platform = 'Linux-4.4.0-104-generic-x86_64-with-Ubuntu-16.04-xenial'
unisphere_version = u'V9.1.0.14'
unisphere_version = u'V9.1.0.17'
unisphere_version_90 = "V9.0.0.1"
openstack_release = '12.0.0.0b3.dev401'
openstack_version = '12.0.0'


+ 1
- 1
cinder/tests/unit/volume/drivers/dell_emc/powermax/test_powermax_rest.py View File

@@ -1785,7 +1785,7 @@ class PowerMaxRestTest(test.TestCase):
ucode = self.rest.get_array_ucode_version(array)
self.assertEqual(self.data.powermax_model_details['ucode'], ucode)

def test_validate_unisphere_version_suceess(self):
def test_validate_unisphere_version_success(self):
version = tpd.PowerMaxData.unisphere_version
returned_version = {'version': version}
with mock.patch.object(self.rest, "request",


+ 1
- 1
cinder/volume/drivers/dell_emc/powermax/rest.py View File

@@ -36,7 +36,7 @@ SLOPROVISIONING = 'sloprovisioning'
REPLICATION = 'replication'
SYSTEM = 'system'
U4V_VERSION = '91'
MIN_U4P_VERSION = '9.1.0.14'
MIN_U4P_VERSION = '9.1.0.17'
UCODE_5978 = '5978'
retry_exc_tuple = (exception.VolumeBackendAPIException,)
u4p_failover_max_wait = 120


Loading…
Cancel
Save