Browse Source

Merge "Mark Nimble Storage Driver supported"

tags/16.0.0.0rc1
Zuul 3 months ago
committed by Gerrit Code Review
parent
commit
79c3b155bb
4 changed files with 9 additions and 5 deletions
  1. +1
    -1
      cinder/tests/unit/volume/drivers/test_nimble.py
  2. +0
    -3
      cinder/volume/drivers/nimble.py
  3. +1
    -1
      doc/source/reference/support-matrix.ini
  4. +7
    -0
      releasenotes/notes/nimble-mark-supported-0c8e5e21c8d1179d.yaml

+ 1
- 1
cinder/tests/unit/volume/drivers/test_nimble.py View File

@@ -15,8 +15,8 @@


import sys
from unittest import mock

import mock
from six.moves import http_client

from cinder import context


+ 0
- 3
cinder/volume/drivers/nimble.py View File

@@ -138,9 +138,6 @@ class NimbleBaseVolumeDriver(san.SanDriver):
# ThirdPartySystems wiki page
CI_WIKI_NAME = "Nimble_Storage_CI"

# TODO(jsbryant) Remove driver in the 'U' release if CI is not fixed.
SUPPORTED = False

def __init__(self, *args, **kwargs):
super(NimbleBaseVolumeDriver, self).__init__(*args, **kwargs)
self.APIExecutor = None


+ 1
- 1
doc/source/reference/support-matrix.ini View File

@@ -233,7 +233,7 @@ driver.netapp_ontap=complete
driver.netapp_solidfire=complete
driver.nexenta=complete
driver.nfs=complete
driver.nimble=missing
driver.nimble=complete
driver.prophetstor=missing
driver.pure=complete
driver.qnap=complete


+ 7
- 0
releasenotes/notes/nimble-mark-supported-0c8e5e21c8d1179d.yaml View File

@@ -0,0 +1,7 @@
---
upgrade:
- |
HPE Nimble Storage drivers had been previously marked unsupported. Testing
requirements have been addressed and they are now fully supported again.
HPE Nimble Storage drivers allow cinder to manage volumes both in iSCSI and
FC environment.

Loading…
Cancel
Save