Browse Source

Merge "Mark Huawei Fusionstorage Driver Unsupported"

changes/88/680588/2
Zuul 1 week ago
parent
commit
8e7726c677

+ 3
- 0
cinder/volume/drivers/fusionstorage/dsware.py View File

@@ -110,6 +110,9 @@ class DSWAREDriver(driver.VolumeDriver):
110 110
     VERSION = '2.0'
111 111
     CI_WIKI_NAME = 'Huawei_FusionStorage_CI'
112 112
 
113
+    # TODO(jsbryant) Remove driver in the 'U' release due to no py37 support.
114
+    SUPPORTED = False
115
+
113 116
     def __init__(self, *args, **kwargs):
114 117
         super(DSWAREDriver, self).__init__(*args, **kwargs)
115 118
 

+ 1
- 1
doc/source/reference/support-matrix.ini View File

@@ -227,7 +227,7 @@ driver.huawei_v5=complete
227 227
 driver.huawei_f_v5=complete
228 228
 driver.huawei_18000=complete
229 229
 driver.huawei_dorado=complete
230
-driver.huawei_fusionstorage=complete
230
+driver.huawei_fusionstorage=missing
231 231
 driver.infinidat=complete
232 232
 driver.ibm_ds8k=complete
233 233
 driver.ibm_flashsystem=missing

+ 15
- 0
releasenotes/notes/huawei-fusionstorage-unsupported-4be766dd2ba8f980.yaml View File

@@ -0,0 +1,15 @@
1
+---
2
+upgrade:
3
+  - |
4
+    The Huawei Fusionstorage driver has been marked as unsupported
5
+    and is now deprecated. ``enable_unsupported_driver`` will need
6
+    to be set to ``True`` in the driver's section in cinder.conf to
7
+    continue to use the driver.
8
+deprecations:
9
+  - |
10
+    The Huawei Fusionstorage driver has been marked as unsupported
11
+    due to a lack of Python3.7 support and is now deprecated.
12
+    ``enable_unsupported_driver`` will need to be set to ``True``
13
+    in the driver's section in cinder.conf to continue to use them.
14
+    If Python3.7 support is not demonstrated, the driver will be
15
+    removed in the 'U' development cycle.

Loading…
Cancel
Save