Browse Source

Merge "Mark Huawei Fusionstorage Driver Unsupported"

tags/15.0.0.0rc1
Zuul 2 months ago
parent
commit
8e7726c677

+ 3
- 0
cinder/volume/drivers/fusionstorage/dsware.py View File

@@ -110,6 +110,9 @@ class DSWAREDriver(driver.VolumeDriver):
VERSION = '2.0'
CI_WIKI_NAME = 'Huawei_FusionStorage_CI'

# TODO(jsbryant) Remove driver in the 'U' release due to no py37 support.
SUPPORTED = False

def __init__(self, *args, **kwargs):
super(DSWAREDriver, self).__init__(*args, **kwargs)


+ 1
- 1
doc/source/reference/support-matrix.ini View File

@@ -227,7 +227,7 @@ driver.huawei_v5=complete
driver.huawei_f_v5=complete
driver.huawei_18000=complete
driver.huawei_dorado=complete
driver.huawei_fusionstorage=complete
driver.huawei_fusionstorage=missing
driver.infinidat=complete
driver.ibm_ds8k=complete
driver.ibm_flashsystem=missing

+ 15
- 0
releasenotes/notes/huawei-fusionstorage-unsupported-4be766dd2ba8f980.yaml View File

@@ -0,0 +1,15 @@
---
upgrade:
- |
The Huawei Fusionstorage driver has been marked as unsupported
and is now deprecated. ``enable_unsupported_driver`` will need
to be set to ``True`` in the driver's section in cinder.conf to
continue to use the driver.
deprecations:
- |
The Huawei Fusionstorage driver has been marked as unsupported
due to a lack of Python3.7 support and is now deprecated.
``enable_unsupported_driver`` will need to be set to ``True``
in the driver's section in cinder.conf to continue to use them.
If Python3.7 support is not demonstrated, the driver will be
removed in the 'U' development cycle.

Loading…
Cancel
Save