Browse Source

Re-add support for python 3.5

cliff is used by stestr which is used by more things than just
openstack projects - one of them being zuul which still supports
python 3.5. Let's keep supporting 3.5 here for now.

Change-Id: I14fca07853677d041215649cb55caf1e0dc49753
tags/3.1.0^0
Monty Taylor 3 months ago
parent
commit
5405c3dfd7
2 changed files with 3 additions and 1 deletions
  1. +1
    -0
      .zuul.yaml
  2. +2
    -1
      setup.cfg

+ 1
- 0
.zuul.yaml View File

@@ -24,6 +24,7 @@
- check-requirements
- lib-forward-testing-python3
- openstack-lower-constraints-jobs
- openstack-python35-jobs
- openstack-python3-ussuri-jobs
- publish-openstack-docs-pti
check:


+ 2
- 1
setup.cfg View File

@@ -5,12 +5,13 @@ author = OpenStack
author-email = openstack-discuss@lists.openstack.org
summary = Command Line Interface Formulation Framework
home-page = https://docs.openstack.org/cliff/latest/
python-requires = >=3.6
python-requires = >=3.5
classifier =
Development Status :: 5 - Production/Stable
License :: OSI Approved :: Apache Software License
Programming Language :: Python
Programming Language :: Python :: 3
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3 :: Only


Loading…
Cancel
Save