Browse Source

Remove cap on cmd2

After [1] and [2], there is no need to cap the version of cmd2.

This will also fix the current "rally_openstack" import problems
experienced in the CI: http://paste.openstack.org/show/794701/

[1]https://review.opendev.org/#/c/712591/
[2]https://review.opendev.org/#/c/734629/

Change-Id: Ie15e3f5058c4bd104978d9f31f0590d6c795024b
tags/3.3.0^0
Rodolfo Alonso Hernandez 3 months ago
committed by Monty Taylor
parent
commit
8099c98249
2 changed files with 11 additions and 1 deletions
  1. +10
    -0
      cliff/interactive.py
  2. +1
    -1
      requirements.txt

+ 10
- 0
cliff/interactive.py View File

@@ -158,6 +158,16 @@ class InteractiveApp(cmd2.Cmd):
]

def precmd(self, statement):
"""Hook method executed just before the command is executed by
:meth:`~cmd2.Cmd.onecmd` and after adding it to history.

:param statement: subclass of str which also contains the parsed input
:return: a potentially modified version of the input Statement object
"""
# NOTE(mordred): The above docstring is copied in from cmd2 because
# current cmd2 has a docstring that sphinx finds if we don't override
# it, and it breaks sphinx.

# Pre-process the parsed command in case it looks like one of
# our subcommands, since cmd2 does not handle multi-part
# command names by default.


+ 1
- 1
requirements.txt View File

@@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
cmd2>=0.8.0,!=0.8.3,<0.9.0 # MIT
cmd2>=0.8.0,!=0.8.3 # MIT
PrettyTable<0.8,>=0.7.2 # BSD
pyparsing>=2.1.0 # MIT
six>=1.10.0 # MIT


Loading…
Cancel
Save