Browse Source

Updated to liberty requirements

Change-Id: I5bf1c920654da62cf870fe24686028450378acd4
changes/42/287842/1
Stéphane Albert 6 years ago
parent
commit
9ca6e2fed5
  1. 2
      requirements.txt
  2. 2
      setup.py
  3. 6
      test-requirements.txt

2
requirements.txt

@ -1,5 +1,5 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=0.7,<1.0,>=0.6
pbr>=1.6
Babel>=1.3

2
setup.py

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr'],
setup_requires=['pbr>=1.8'],
pbr=True)

6
test-requirements.txt

@ -7,8 +7,8 @@ coverage>=3.6
discover
python-subunit>=0.0.18
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
oslosphinx<2.6.0,>=2.5.0 # Apache-2.0
oslotest<1.6.0,>=1.5.1 # Apache-2.0
oslosphinx>=2.5.0 # Apache-2.0
oslotest>=1.10.0 # Apache-2.0
testrepository>=0.0.18
testscenarios>=0.4
testtools!=1.2.0,>=0.9.36
testtools>=1.4.0
Loading…
Cancel
Save