Browse Source

Drop Django 1.11 support

Django 1.11 ends its extended support in April 2020 (which is before
Ussuri release), so horizon drops Django 1.11 support in Ussuri.

tox envs for non-primary Django versions are no longer needed in tox.ini
as testing environments for non-primary Django versions are setup in
the zuul jobs now.

horizon>=17.1.0 is required to use Django 2.2.
requirements.txt is updated accordingly.
For more info. please refer [1], [2].

[1] https://review.opendev.org/#/c/700733/
[2] https://etherpad.openstack.org/p/Enable_Django22_support_in_Horizon_Plugin

Change-Id: I6f393b85306e514f9e00567dfd2b9940d6f26253
changes/39/700839/3
manchandavishal 2 years ago
parent
commit
cade8de984
  1. 1
      requirements.txt
  2. 4
      test-requirements.txt
  3. 4
      tox.ini

1
requirements.txt

@ -5,5 +5,6 @@
pbr!= 2.1.0,>=2.0.0
Babel>=1.3
python-cloudkittyclient>=0.5.0
horizon>=17.1.0 # Apache-2.0
XStatic-D3>=3.5.17.0
XStatic-Rickshaw>=1.5

4
test-requirements.txt

@ -2,10 +2,6 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=1.1.0,<1.2.0 # Apache-2.0
# Require Horizon
-e git://github.com/openstack/horizon.git#egg=horizon
coverage>=3.6
python-subunit>=0.0.18
oslotest>=1.10.0 # Apache-2.0

4
tox.ini

@ -1,6 +1,6 @@
[tox]
minversion = 2.0
envlist = py36,py37,py3-{dj111,dj22},pypy,pep8
envlist = py36,py37,pep8
skipsdist = True
[testenv]
@ -12,8 +12,6 @@ setenv =
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands =
dj111: pip install django>=1.11,<2
dj22: pip install django>=2.2,<2.3
stestr run --slowest {posargs}
[testenv:pep8]

Loading…
Cancel
Save