More cleanup for py2 drop

This commit cleanup requirement file and add
ignore_basepython_conflict flag into tox to avoid
python version conflct.

Change-Id: Ie7a80ac58dc425e66cf2b7334b99e22a07759dbc
changes/77/704077/1 2.0.0
Ghanshyam 3 years ago
parent 91c85d04ca
commit 44b8c4ed91
  1. 2
      test-requirements.txt
  2. 3
      tox.ini

@ -6,7 +6,7 @@ hacking>=1.1.0,<1.2.0 # Apache-2.0
coverage>=4.0,!=4.4 # Apache-2.0
python-subunit>=0.0.18 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
oslotest>=1.10.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
testtools>=1.4.0 # MIT

@ -1,7 +1,8 @@
[tox]
minversion = 2.0
minversion = 3.1.1
envlist = py36,py37,pypy,pep8
skipsdist = True
ignore_basepython_conflict = True
[testenv]
basepython = python3

Loading…
Cancel
Save