Browse Source

Get rid of dependency on python cookbook

The python cookbook is deprecated, so we should get rid of it, in
particular as we do not seem to need it anymore.

Change-Id: I4320035a0fff6479d96215239eec9006b4e79754
Jens Rosenboom 3 years ago
parent
commit
6ce1eb3be6
3 changed files with 0 additions and 6 deletions
  1. 0
    1
      README.md
  2. 0
    1
      metadata.rb
  3. 0
    4
      spec/scheduler-redhat_spec.rb

+ 0
- 1
README.md View File

@@ -20,7 +20,6 @@ The following cookbooks are dependencies:
20 20
 * openstack-identity
21 21
 * openstack-image
22 22
 * selinux (Fedora)
23
-* python
24 23
 
25 24
 Usage
26 25
 =====

+ 0
- 1
metadata.rb View File

@@ -24,4 +24,3 @@ depends 'openstack-common', '>= 13.0.0'
24 24
 depends 'openstack-identity', '>= 13.0.0'
25 25
 depends 'openstack-image', '>= 13.0.0'
26 26
 depends 'selinux', '~> 0.9.0'
27
-depends 'python', '~> 1.4.6'

+ 0
- 4
spec/scheduler-redhat_spec.rb View File

@@ -24,10 +24,6 @@ describe 'openstack-block-storage::scheduler' do
24 24
       expect(chef_run).to enable_service 'openstack-cinder-scheduler'
25 25
     end
26 26
 
27
-    it 'does not upgrade stevedore' do
28
-      expect(chef_run).not_to upgrade_python_pip 'stevedore'
29
-    end
30
-
31 27
     it 'upgrades mysql python package' do
32 28
       expect(chef_run).to upgrade_package 'MySQL-python'
33 29
     end

Loading…
Cancel
Save